summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/blender/PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/blender/PKGBUILD b/community/blender/PKGBUILD
index 4a583535..35b2c970 100644
--- a/community/blender/PKGBUILD
+++ b/community/blender/PKGBUILD
@@ -1,11 +1,14 @@
makedepends=(
${makedepends[@]/cuda/}
)
+depends=(
+ ${depends[@]/openimagedenoise/}
+)
pkgdesc+=", without nonfree CUDA support"
eval "$(
declare -f build \
| sed '
- /^cmake / s/$/ -DWITH_CYCLES_CUDA_BINARIES=OFF -DWITH_CYCLES_DEVICE_CUDA=OFF
+ /^\s*cmake / s/;$/ -DWITH_CYCLES_CUDA_BINARIES=OFF -DWITH_CYCLES_DEVICE_CUDA=OFF -DWITH_RAYOPTIMIZATION=OFF;/
'
)"
source_i686+=('arm-no-sse2.patch')