summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/sarg/PKGBUILD8
-rw-r--r--community/sarg/no-werror.patch23
2 files changed, 31 insertions, 0 deletions
diff --git a/community/sarg/PKGBUILD b/community/sarg/PKGBUILD
new file mode 100644
index 00000000..6c188a3b
--- /dev/null
+++ b/community/sarg/PKGBUILD
@@ -0,0 +1,8 @@
+source+=(no-werror.patch)
+sha256sums+=(42744656ddc442d7823859f170750c4b69e5dc599230218dd3016f7a74809a4d)
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -p1 -i "$srcdir"/no-werror.patch
+ '
+)"
diff --git a/community/sarg/no-werror.patch b/community/sarg/no-werror.patch
new file mode 100644
index 00000000..7d04349b
--- /dev/null
+++ b/community/sarg/no-werror.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aac6933..aa784ea 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,18 +71,6 @@ IF(HAVE_WEXTRA)
+ SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Wextra -Wno-unused-parameter")
+ ENDIF(HAVE_WEXTRA)
+
+-CHECK_C_COMPILER_FLAG("-Werror=implicit-function-declaration" HAVE_WERROR_IMPLICIT_FUNCTION)
+-IF(HAVE_WERROR_IMPLICIT_FUNCTION)
+- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
+- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=implicit-function-declaration")
+-ENDIF(HAVE_WERROR_IMPLICIT_FUNCTION)
+-
+-CHECK_C_COMPILER_FLAG("-Werror=format" HAVE_WERROR_FORMAT)
+-IF(HAVE_WERROR_FORMAT)
+- GET_TARGET_PROPERTY(TMPCFLAGS sarg COMPILE_FLAGS)
+- SET_TARGET_PROPERTIES(sarg PROPERTIES COMPILE_FLAGS "${TMPCFLAGS} -Werror=format")
+-ENDIF(HAVE_WERROR_FORMAT)
+-
+ # Required header files
+ CHECK_INCLUDE_FILE(stdio.h HAVE_STDIO_H)
+ CHECK_INCLUDE_FILE(stdlib.h HAVE_STDLIB_H)