summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libmongoc/PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/community/libmongoc/PKGBUILD b/community/libmongoc/PKGBUILD
index 07549822..6dfd1110 100644
--- a/community/libmongoc/PKGBUILD
+++ b/community/libmongoc/PKGBUILD
@@ -1,2 +1,8 @@
# mongodb is not available for i686
checkdepends=("${checkdepends[@]/mongodb/}")
+
+# _this_ check function only prints a warning on failing tests - this will not be seen by the build slave & master anyway
+if [ "$(declare -f check | sha512sum | cut -d' ' -f1)" = '87bfbc049fd94802f6fceaff393fa210f1679dba86d1a572a523b13eed5afa0d378695348194f5eb4d4a7629a7ff4cb5da0a763b858fbfe62813ee58f903aceb' ]; then
+ unset checkdepends
+ unset check
+fi