summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/clingo/PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/clingo/PKGBUILD b/community/clingo/PKGBUILD
index cf5c4a59..b41d5d41 100644
--- a/community/clingo/PKGBUILD
+++ b/community/clingo/PKGBUILD
@@ -1,9 +1,10 @@
# see upstream: https://github.com/potassco/clingo/issues/57
source+=("clang-libatomic.patch::https://github.com/potassco/clasp/commit/fe3e176e2813956000bb947479de2c3d80fe34be.patch")
-sha256sums+=('222b535ffd761c07c3652a3025180bcfb1f1b7504d7353048d5ce485a84c1a27')
+md5sums+=('d78671719de4e36653acf0ef28f890ae')
prepare() {
- cd $pkgname-$pkgver/clasp
+ cd $pkgname/clasp
patch -p1 -i ../../clang-libatomic.patch
+ find . -name '*.cpp' -type f -exec sed -i '/^#include <xlocale\.h>$/d' {} \;
}