summaryrefslogtreecommitdiff
path: root/community/squid
diff options
context:
space:
mode:
Diffstat (limited to 'community/squid')
-rw-r--r--community/squid/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/squid/PKGBUILD b/community/squid/PKGBUILD
new file mode 100644
index 00000000..53731943
--- /dev/null
+++ b/community/squid/PKGBUILD
@@ -0,0 +1,13 @@
+# testing libatomic for __atomic_load_8 fails in configure.ac, following the idea in
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=830942
+# TODO: report upstream in squid project
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|make|make LDFLAGS=="-Wl,--as-needed -latomic -Wl,--no-as-needed"|g
+ ';
+ )"
+fi