summaryrefslogtreecommitdiff
path: root/community/python-shapely/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-shapely/PKGBUILD')
-rw-r--r--community/python-shapely/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/community/python-shapely/PKGBUILD b/community/python-shapely/PKGBUILD
new file mode 100644
index 00000000..6d774d77
--- /dev/null
+++ b/community/python-shapely/PKGBUILD
@@ -0,0 +1,23 @@
+# temporary fix for:
+# - https://github.com/Toblerity/Shapely/pull/762
+#
+# which caused:
+# - https://community.ultimaker.com/topic/29721-archlinux32-cura-341/?_fromLogin=1#replyForm
+#
+source+=(load_dll_c.patch)
+sha512sums+=('79560d71d2d63d1f173612dec02d1f077a788fb15f5ba3cb64102e62a1e11ec0acc2dc3355b49b154ff90d606ce89e977cbd843af9b81b0dcafc677596f6492e')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i cd Shapely-$pkgver && patch -p1 -i "$srcdir/load_dll_c.patch"
+ '
+)"
+
+# patch CARCH to always use i686 build directory during testing
+eval "$(
+ declare -f check | \
+ sed '
+ /.*py.test/s/\$CARCH/i686/
+ '
+)"