summaryrefslogtreecommitdiff
path: root/community/python-redis/tmp
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-redis/tmp')
-rw-r--r--community/python-redis/tmp68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/python-redis/tmp b/community/python-redis/tmp
new file mode 100644
index 00000000..6381b912
--- /dev/null
+++ b/community/python-redis/tmp
@@ -0,0 +1,68 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Karol 'Kenji Takahashi' Woźniak <kenji.sx>
+# Contributor: Pierre Gueth <pierre.gueth@gmail.com>
+
+pkgbase=python-redis
+pkgname=('python-redis' 'python2-redis')
+pkgver=2.10.6
+pkgrel=1
+pkgdesc='The Python interface to the Redis key-value store'
+arch=('any')
+url="http://github.com/andymccurdy/redis-py"
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest' 'python2-pytest' 'python-mock' 'python2-mock' 'python-pifpaf' 'redis')
+source=("https://pypi.io/packages/source/r/redis/redis-$pkgver.tar.gz" precision.patch)
+sha512sums=('e7df464bc3b26e23f6a0d2d2896306c1e4792b9a2a4ecaea6dd8690ffa17853cc85345f063307295dd3c2da399f7f203f4b21d785f7e073c0501732257419dad' 'SKIP')
+
+prepare() {
+ patch -p0 -i precision.patch
+ cp -a redis-$pkgver{,-py2}
+}
+
+build() {
+ cd redis-$pkgver
+ python setup.py build
+
+ cd ../redis-$pkgver-py2
+ python2 setup.py build
+}
+
+check() {
+ cd redis-$pkgver
+ pifpaf run redis py.test
+
+ cd ../redis-$pkgver-py2
+ pifpaf run redis py.test2
+}
+
+package_python-redis() {
+ depends=('python')
+
+ cd redis-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-redis() {
+ depends=('python2')
+
+ cd redis-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
+# see https://github.com/andymccurdy/redis-py/issues/899
+
+source+=('precision.patch')
+sha512sums+=('ccefada444c145f78098a37880bf7b1c7a2f2e24e92efc62f084610064c4391e4e0792a3e380ca940b73b15d703d5d0f166a8f7d8d17b9d84772b3e870fb74d5')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /^{/ a \
+ patch -p0 -i precision.patch
+ '
+)"