summaryrefslogtreecommitdiff
path: root/community/python-distro/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/python-distro/PKGBUILD')
-rw-r--r--community/python-distro/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/python-distro/PKGBUILD b/community/python-distro/PKGBUILD
new file mode 100644
index 00000000..32d99307
--- /dev/null
+++ b/community/python-distro/PKGBUILD
@@ -0,0 +1,30 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/make man SPHINXBUILD=sphinx-build2//
+ s/make man SPHINXBUILD=sphinx-build//
+ '
+ )"
+
+ eval "$(
+ declare -f package_python-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_python2-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ unset check
+fi