summaryrefslogtreecommitdiff
path: root/community/libavif
diff options
context:
space:
mode:
Diffstat (limited to 'community/libavif')
-rw-r--r--community/libavif/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/libavif/PKGBUILD b/community/libavif/PKGBUILD
index 21f0f5ad..10c53c42 100644
--- a/community/libavif/PKGBUILD
+++ b/community/libavif/PKGBUILD
@@ -6,3 +6,15 @@ eval "$(
s/-DAVIF_CODEC_SVT=ON/-DAVIF_CODEC_SVT=OFF/
'
)"
+
+# on i486 we ignore rav1e for now (needs rust)
+if [ "$CARCH" = 'i486' ]; then
+ depends=(${depends[@]//rav1e/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-DAVIF_CODEC_RAV1E=ON/-DAVIF_CODEC_RAV1E=OFF/
+ '
+ )"
+fi
+