summaryrefslogtreecommitdiff
path: root/community/kea
diff options
context:
space:
mode:
Diffstat (limited to 'community/kea')
-rw-r--r--community/kea/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/kea/PKGBUILD b/community/kea/PKGBUILD
new file mode 100644
index 00000000..1d5103ad
--- /dev/null
+++ b/community/kea/PKGBUILD
@@ -0,0 +1,19 @@
+# on i486, mariadb is unavailable for quite some time, now
+
+depends=(${depends[@]//mariadb-libs/})
+depends_pentium4+=(mariadb-libs)
+depends_i686+=(mariadb-libs)
+
+eval "$(
+ declare -f build \
+ | sed '
+ /configure/ {
+ h
+ s/^/[ "$CARCH" = i486 ] || /
+ p
+ g
+ s/^/[ "$CARCH" != i486 ] || /
+ s/--with-mysql/--without-mysql/
+ }
+ '
+)"