summaryrefslogtreecommitdiff
path: root/build-support/rust148/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/rust148/PKGBUILD')
-rw-r--r--build-support/rust148/PKGBUILD202
1 files changed, 202 insertions, 0 deletions
diff --git a/build-support/rust148/PKGBUILD b/build-support/rust148/PKGBUILD
new file mode 100644
index 00000000..436799c2
--- /dev/null
+++ b/build-support/rust148/PKGBUILD
@@ -0,0 +1,202 @@
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: userwithuid <userwithuid@gmail.com>
+
+pkgname=('rust148' 'rust148-docs')
+epoch=1
+pkgver=1.48.0
+pkgrel=1
+
+_llvm_ver=11.0.0
+
+pkgdesc='Systems programming language focused on safety, speed and concurrency'
+url='https://www.rust-lang.org/'
+arch=(i486 i686 pentium4 'x86_64')
+license=('MIT' 'Apache')
+
+makedepends=('rust=1:1.47.0' "llvm10-libs" "llvm=$_llvm_ver" 'libffi' 'perl' 'python' 'curl' 'cmake')
+checkdepends=('procps-ng' 'gdb')
+
+options=('!emptydirs')
+
+source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
+ "https://github.com/llvm/llvm-project/releases/download/llvmorg-$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz"{,.sig})
+
+sha256sums=('0e763e6db47d5d6f91583284d2f989eacc49b84794d1443355b85c58d67ae43b'
+ 'SKIP'
+ '374aff82ff573a449f9aabbd330a5d0a441181c535a3599996127378112db234'
+ 'SKIP')
+validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
+ '474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
+ 'B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
+
+prepare() {
+ cd "rustc-$pkgver-src"
+
+ cat >config.toml <<END
+[llvm]
+link-shared = true
+
+[build]
+target = ["x86_64-unknown-linux-gnu", "i686-unknown-linux-gnu"]
+cargo = "/usr/bin/cargo"
+rustc = "/usr/bin/rustc"
+python = "/usr/bin/python"
+extended = true
+sanitizers = false
+profiler = true
+vendor = true
+
+[install]
+prefix = "/usr"
+
+[rust]
+# LLVM crashes when passing an object through ThinLTO twice. This is triggered when using rust
+# code in cross-language LTO if libstd was built using ThinLTO.
+# http://blog.llvm.org/2019/09/closing-gap-cross-language-lto-between.html
+# https://github.com/rust-lang/rust/issues/54872
+codegen-units-std = 1
+
+debuginfo-level = 2
+
+channel = "stable"
+
+rpath = false
+
+[target.x86_64-unknown-linux-gnu]
+llvm-config = "/usr/bin/llvm-config"
+END
+}
+
+build() {
+ cd "rustc-$pkgver-src"
+
+ export RUST_BACKTRACE=1
+ export RUST_COMPILER_RT_ROOT="$srcdir/compiler-rt-$_llvm_ver.src"
+
+ python ./x.py dist -j "$(nproc)"
+ DESTDIR="$PWD"/dest-rust python ./x.py install -j "$(nproc)"
+
+ # move docs and lib32 libs out of the way for splitting
+ mv dest-rust/usr/lib/rustlib/i686-unknown-linux-gnu dest-i686
+ mv dest-rust/usr/share/doc dest-doc
+}
+
+package_rust148() {
+ depends=('gcc-libs' 'llvm-libs' 'curl' 'libssh2')
+ optdepends=('lldb: rust-lldb script'
+ 'gdb: rust-gdb script')
+ provides=('cargo' 'rustfmt')
+ conflicts=('cargo' 'rustfmt')
+ replaces=('cargo' 'rustfmt')
+
+ cd "rustc-$pkgver-src"
+
+ mv dest-rust/* "$pkgdir"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE*
+
+ # delete unnecesary files, e.g. components and manifest files only used for the uninstall script
+ cd "$pkgdir"/usr/lib/rustlib
+ rm components install.log manifest-* rust-installer-version uninstall.sh
+
+ # rustbuild always installs copies of the shared libraries to /usr/lib,
+ # overwrite them with symlinks to the per-architecture versions
+ ln -srft "$pkgdir"/usr/lib x86_64-unknown-linux-gnu/lib/*.so
+
+ install -d "$pkgdir"/usr/share/bash-completion
+ mv "$pkgdir"/etc/bash_completion.d/ "$pkgdir"/usr/share/bash-completion/completions/
+}
+
+package_lib32-rust-libs() {
+ descriptino=('32-bit libraries for Rust')
+ depends=('lib32-gcc-libs')
+ provides=('lib32-rust')
+ conflicts=('lib32-rust')
+ replaces=('lib32-rust')
+
+ cd "rustc-$pkgver-src"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE*
+
+ install -d "$pkgdir"/usr/lib/rustlib/ "$pkgdir"/usr/lib32/
+ mv dest-i686 "$pkgdir"/usr/lib/rustlib/i686-unknown-linux-gnu
+ ln -srft "$pkgdir"/usr/lib32 "$pkgdir"/usr/lib/rustlib/i686-unknown-linux-gnu/lib/*.so
+}
+
+package_rust148-docs() {
+ description=('Documentation for the Rust programming language')
+
+ cd "rustc-$pkgver-src"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE*
+
+ install -d "$pkgdir"/usr/share/doc
+ mv dest-doc/* "$pkgdir"/usr/share/doc
+}
+
+# vim:set ts=2 sw=2 et:
+# enable i686-unknown-linux-gnu target
+# and replace pentium4 (SSE2) with pentium3 (no SSE2) in the compiler spec file
+#
+# Also trying to reduce memory usage by building with
+# -debuginfo-level-std=1
+# see https://github.com/rust-lang/rust/issues/60294
+
+source+=(config.toml.patch)
+sha256sums+=('42e861ba90335d0e2e666e10b12d9ff85ea1bdb711176fb3c09e92375e193660')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/config.toml.patch"
+ '
+)"
+
+# stop insanity of nproc (see FS#62952)
+eval "$(
+ declare -f build | \
+ sed '
+ s/-j"$(nproc)"/-j16/
+ '
+)"
+
+if [ "${CARCH}" != 'pentium4' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/vendor/rustc-ap-rustc_target/src/spec/i686_unknown_linux_gnu.rs"
+ $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs"
+ $ i sed -i "s/30f6a25d37d536c5734b9a7e1e9cc34167a013c5e0c49c3fe0a26d76f2e1ae6c/412f837953e4cc32ff14195bf2da7eb61cb43d602fdc2db1099997d906070521/g" "$srcdir/rustc-$pkgver-src/vendor/rustc-ap-rustc_target/.cargo-checksum.json"
+ '
+ )"
+fi
+
+# Don't move lib32 support into rust32-lib, we are on 32-bit in the end
+# and don't draw a symlink to 64-bit libraries (but to 32-bit instead)
+
+pkgname=(
+ $(
+ printf '%s\n' "${pkgname[@]}" | \
+ grep -v '^lib32-rust-libs'
+ )
+)
+
+eval "$(
+ declare -f package_rust148 | \
+ sed '
+ /mv.*i686-unknown-linux-gnu.*/d
+ /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /mv.*i686-unknown-linux-gnu.*/d
+ /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
+ '
+)"
+
+# Enable on demand, if your previous rust is broken, see also build-support and AUR
+# for rust-bin.
+#makedepends=(${makedepends[@]//rust/})
+#makedepends+=('rust-bin')