summaryrefslogtreecommitdiff
path: root/build-support/python-six-nocheck
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-six-nocheck')
-rw-r--r--build-support/python-six-nocheck/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/build-support/python-six-nocheck/PKGBUILD b/build-support/python-six-nocheck/PKGBUILD
new file mode 100644
index 00000000..82664eb9
--- /dev/null
+++ b/build-support/python-six-nocheck/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Erich Eckner <deep42thought at archlinux32 dot org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+# Contributer: Allan McRae <allan@archlinux.org>
+
+# heavily borrowed from python-six's PKGBUILD
+
+pkgbase=python-six-nocheck
+pkgname=('python2-six-nocheck' 'python-six-nocheck')
+pkgver=1.15.0
+pkgrel=3
+pkgdesc="Python 2 and 3 compatibility utilities"
+arch=('any')
+url="https://pypi.python.org/pypi/six/"
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
+sha512sums=('eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9')
+
+build() {
+ cp -a six-$pkgver{,-py2}
+}
+
+package_python-six-nocheck() {
+ depends=('python')
+ provides=("python-six=$pkgver")
+ conflicts=('python-six')
+
+ cd six-$pkgver
+ python setup.py install --root "$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-six-nocheck() {
+ depends=('python2')
+ provides=("python-six=$pkgver")
+ conflicts=('python-six')
+
+ cd six-$pkgver-py2
+ python2 setup.py install --root "$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}