summaryrefslogtreecommitdiff
path: root/build-support/python-setuptools-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/python-setuptools-bootstrap/PKGBUILD')
-rw-r--r--build-support/python-setuptools-bootstrap/PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/build-support/python-setuptools-bootstrap/PKGBUILD b/build-support/python-setuptools-bootstrap/PKGBUILD
index edefd64d..8b46c9e3 100644
--- a/build-support/python-setuptools-bootstrap/PKGBUILD
+++ b/build-support/python-setuptools-bootstrap/PKGBUILD
@@ -8,16 +8,17 @@
# heavily borrowed from python-setuptools' PKGBUILD
pkgname=python-setuptools-bootstrap
-pkgver='55.0.0'
-pkgrel='1'
+_pkgname="${pkgname%-*}"
+pkgver='56.2.0'
+pkgrel='2'
epoch='1'
pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages - bootstrap variant"
arch=('any')
license=('PSF')
url="https://pypi.org/project/setuptools/"
makedepends=('python' 'git')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz")
-sha512sums=('09ef700a076cac07d552a2faf54f48b040944852521bfe357f2ef4dec79d8f87b8d285640cf698a490b0289ba974a06b1c39c32ea0acbfa56e582e4bb68ffdf7')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz")
+sha512sums=('ff062db8adf4478bb55650e0c5ef162aed1e4de2b6dba8c0b6ea986b669ef2c8af126247f281feb749cd8a54c0bd9af54e99289073ab742b0d4e26a0208b963c')
export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
@@ -55,5 +56,7 @@ package() {
replaces=('python-distribute')
cd "$srcdir"/setuptools-$pkgver
+ # create directory before installing (otherwise installing fails)
+ mkdir build/scripts-3.10
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
}