summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/python-scipy/PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/python-scipy/PKGBUILD b/community/python-scipy/PKGBUILD
index 7791f788..26b3f417 100644
--- a/community/python-scipy/PKGBUILD
+++ b/community/python-scipy/PKGBUILD
@@ -1,10 +1,8 @@
# increase standard relative tolerance of verify_gauss_quad
-prepare() {
- sed -i '
- /def verify_gauss_quad/ {
- N
- s/rtol=[^,]\+,/rtol=2e-15,/
- }
- ' "scipy-${pkgver}/scipy/special/tests/test_orthogonal.py"
-}
+eval "$(
+ declare -f prepare | \
+ sed '
+ 2 a sed -i '"'"'/def verify_gauss_quad/ { N; s/rtol=[^,]\+,/rtol=2e-15,/; } '"'"' "scipy-${pkgver}/scipy/special/tests/test_orthogonal.py"
+ '
+)"