summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/linux-zen/PKGBUILD6
-rw-r--r--extra/linux-zen/config10
2 files changed, 5 insertions, 11 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index b4269f6e..91a471de 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: 69120f9329dd9aee481fdf2050aa7c9f33c311de
+# upstream git revision: d2ec0a9fa29e2d9ae1b73278c8833d30db8cdc93
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'ee3627d42ebdcb8208ef906319adaab8f86eb59fc16641026d9bcc8753b2ab8f' ]; then
- sha256sums[${i}]='db467e92228a11bb1630adf2870c89331ef480ac93087e6b22b62cca53435ffb'
+ if [ "${sha256sums[${i}]}" = 'd2560a0a58611273b95da4c51a9583b7965404d011bb8f0e46f9b668167c07fc' ]; then
+ sha256sums[${i}]='647e2ca59634e71a24df9ec2f0033a8ac1224940d16cbdad437eda4a241c7d1a'
fi
done
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index 658ff536..b858726c 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.11.1-zen1 Kernel Configuration
+# Linux/x86 5.11.4-zen1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 10.2.0"
CONFIG_CC_IS_GCC=y
@@ -252,6 +252,7 @@ CONFIG_BPF_SYSCALL=y
# CONFIG_BPF_PRELOAD is not set
# CONFIG_USERFAULTFD is not set
CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE=y
+CONFIG_KCMP=y
CONFIG_RSEQ=y
# CONFIG_EMBEDDED is not set
CONFIG_HAVE_PERF_EVENTS=y
@@ -10012,14 +10013,7 @@ CONFIG_BINARY_PRINTF=y
#
# Library routines
#
-
-#
-# RAID 6
-#
CONFIG_RAID6_PQ=m
-# CONFIG_RAID6_FORCE_ALGO is not set
-# end of RAID 6
-
# CONFIG_RAID6_PQ_BENCHMARK is not set
CONFIG_LINEAR_RANGES=y
CONFIG_PACKING=y