summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--blacklist/pentium4/gcc10/gcc101
-rw-r--r--blacklist/pentium4/gcc10/gcc10-fortran1
-rw-r--r--extra/qt6-base/PKGBUILD11
3 files changed, 11 insertions, 2 deletions
diff --git a/blacklist/pentium4/gcc10/gcc10 b/blacklist/pentium4/gcc10/gcc10
deleted file mode 100644
index c7effb6f..00000000
--- a/blacklist/pentium4/gcc10/gcc10
+++ /dev/null
@@ -1 +0,0 @@
-There is no need for gcc 10, use a modern gcc, the old one is there for Cuda only (which is not really supported on 32-bit anymore anyway)
diff --git a/blacklist/pentium4/gcc10/gcc10-fortran b/blacklist/pentium4/gcc10/gcc10-fortran
deleted file mode 100644
index c7effb6f..00000000
--- a/blacklist/pentium4/gcc10/gcc10-fortran
+++ /dev/null
@@ -1 +0,0 @@
-There is no need for gcc 10, use a modern gcc, the old one is there for Cuda only (which is not really supported on 32-bit anymore anyway)
diff --git a/extra/qt6-base/PKGBUILD b/extra/qt6-base/PKGBUILD
new file mode 100644
index 00000000..a5dc07b9
--- /dev/null
+++ b/extra/qt6-base/PKGBUILD
@@ -0,0 +1,11 @@
+# add -latomic where needed (i486)
+if [ "$CARCH" = 'i486' ]; then
+ source+=('qtbase-everywhere-src-6.1.0-atomic.patch')
+ sha256sums+=('425e92fef5fe05530a73e80d00d574436de39101c27ffcf4901626598d997e5c')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*nostrip.*/ a \ patch -d $_pkgfn -p1 -i "${srcdir}/qtbase-everywhere-src-6.1.0-atomic.patch"
+ '
+ )"
+fi