summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/binutils/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index a3f00f0f..711a8ed0 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -25,3 +25,14 @@ eval "$(
/0004-PR22868/a patch -p1 -i ${srcdir}/binutils-2.30-glibc-segfault.patch
'
)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable CET (Control Flow instructions endbr32/enbr64)
+ eval "$(
+ declare -f build | \
+ sed '
+ s,configure",configure" --disable-cet,
+ '
+ )"
+fi