summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--blacklist1
-rw-r--r--community/teamspeak3-server/PKGBUILD14
2 files changed, 14 insertions, 1 deletions
diff --git a/blacklist b/blacklist
index 271081c4..8bc1b19e 100644
--- a/blacklist
+++ b/blacklist
@@ -60,6 +60,7 @@ pentium4 skia-sharp # does not provide a bin/gn for 32-bit Linux, see FS32#8
pentium4 skia-sharp58 # does not provide a bin/gn for 32-bit Linux, see FS32#8
pentium4 skia-sharp60 # does not provide a bin/gn for 32-bit Linux, see FS32#8
pentium4 tarantool # hand-crafted assembly code, see <a href="https://github.com/tarantool/tarantool/issues/3029">upstream</a>
+i486 teamspeak3-server # no need and most likely not running on i486
pentium4 vc # "Unsupported target architecture 'i686'. No support_???.cpp file exists for this architecture", complain upstream if you need it
pentium4 wiredtiger # WiredTiger requires a 64-bit build
pentium4 zcash # <a href="https://github.com/zcash/zcash/issues/914">We don't yet support 32bit systems (and we won't by launch) but we can look into this after launch.</a>
diff --git a/community/teamspeak3-server/PKGBUILD b/community/teamspeak3-server/PKGBUILD
index 08d7c2f0..e4231ad2 100644
--- a/community/teamspeak3-server/PKGBUILD
+++ b/community/teamspeak3-server/PKGBUILD
@@ -1,2 +1,14 @@
-sha256sums_i686=('d20d1df1d27445c117b47926e70ebd4c62e0338f18aab2c5d2c218ae6c2b0369')
+sha256sums_i686=('d9ace85f222768f290f50420a845bdbcbb1688d9c0eb477be1171992eccb1140')
+source_pentium4=("${source_i686[@]}")
sha256sums_pentium4=("${sha256sums_i686[@]}")
+
+# set _TSARCH for pentium4 directly instead of trying to patch the
+# if CARCH -> _TSRACH=...
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f package | \
+ sed '
+ s/${_TSARCH}/x86/g
+ '
+ )"
+fi