summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/rust/PKGBUILD2
-rw-r--r--extra/rust/config.toml.patch23
2 files changed, 16 insertions, 9 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index b8c419ce..c0608b3c 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('a077c28d067f5a0b12fcd4898919773929ff76b788af5ae18bfee7275914076e')
+sha256sums+=('fcd8125f57295537a4f775c5b1966e548d9ac453fce513061d39957a1d0cfa45')
eval "$(
declare -f prepare | \
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index 56a3375b..6488342b 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,7 +1,16 @@
diff -rauN a/config.toml b/config.toml
---- a/config.toml 2019-09-08 16:33:31.482763985 +0200
-+++ b/config.toml 2019-09-08 16:35:23.644130362 +0200
-@@ -19,7 +19,7 @@
+--- a/config.toml 2019-09-09 08:53:02.796809788 +0200
++++ b/config.toml 2019-09-09 08:53:42.249120606 +0200
+@@ -2,7 +2,7 @@
+ link-shared = true
+
+ [build]
+-target = ["x86_64-unknown-linux-gnu"] # defaults to just the build triple
++target = ["i686-unknown-linux-gnu"] # defaults to just the build triple
+ cargo = "/usr/bin/cargo"
+ rustc = "/usr/bin/rustc"
+ python = "python"
+@@ -19,11 +19,11 @@
# https://github.com/rust-lang/rust/issues/47745
codegen-units = 1
@@ -10,10 +19,8 @@ diff -rauN a/config.toml b/config.toml
channel = "stable"
-@@ -27,3 +27,6 @@
+ rpath = false
- [target.x86_64-unknown-linux-gnu]
- llvm-config = "/usr/bin/llvm-config"
-+
+-[target.x86_64-unknown-linux-gnu]
+[target.i686-unknown-linux-gnu]
-+llvm-config = "/usr/bin/llvm-config"
+ llvm-config = "/usr/bin/llvm-config"