summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/pcre2/PKGBUILD2
-rw-r--r--extra/git/PKGBUILD1
-rw-r--r--extra/jsoncpp/PKGBUILD18
3 files changed, 18 insertions, 3 deletions
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
index 0cf66cff..da90f860 100644
--- a/core/pcre2/PKGBUILD
+++ b/core/pcre2/PKGBUILD
@@ -10,6 +10,4 @@ if [ "${CARCH}" = "i486" ]; then
s/--enable-jit/--disable-jit/
'
)"
-
-
fi
diff --git a/extra/git/PKGBUILD b/extra/git/PKGBUILD
index 4e8184da..d78c5181 100644
--- a/extra/git/PKGBUILD
+++ b/extra/git/PKGBUILD
@@ -1,6 +1,5 @@
# 486-specific
if [ "${CARCH}" = "i486" ]; then
- echo 486
# we currently have no Gnome and libsecret, so disable integration
makedepends=(${makedepends[@]//libgnome-keyring/})
makedepends=(${makedepends[@]//libsecret/})
diff --git a/extra/jsoncpp/PKGBUILD b/extra/jsoncpp/PKGBUILD
new file mode 100644
index 00000000..a9b60ed8
--- /dev/null
+++ b/extra/jsoncpp/PKGBUILD
@@ -0,0 +1,18 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no doxygen or graphviz
+ makedepends=(${makedepends[@]//doxygen/})
+ makedepends=(${makedepends[@]//graphviz/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /python doxybuild.py/d
+ '
+ declare -f package_jsoncpp-doc | \
+ sed '
+ /cp -a dist\/doxygen/d
+ '
+ )"
+fi
+
+