summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/tigervnc/PKGBUILD21
-rw-r--r--extra/qt5-webkit/PKGBUILD6
2 files changed, 27 insertions, 0 deletions
diff --git a/community/tigervnc/PKGBUILD b/community/tigervnc/PKGBUILD
new file mode 100644
index 00000000..78915425
--- /dev/null
+++ b/community/tigervnc/PKGBUILD
@@ -0,0 +1,21 @@
+# Java currently broken on i486
+# DRI3 has a "configure: error: DRI3 requested, but xshmfence not found." problem currently on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//java-environment=8/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-DBUILD_JAVA=TRUE/-DBUILD_JAVA=FALSE/
+ s/--enable-dri3/--disable-dri3/
+ '
+ )
+ "
+ eval "$(
+ declare -f package | \
+ sed '
+ /VncViewer.jar/d
+ '
+ )
+ "
+fi
+
diff --git a/extra/qt5-webkit/PKGBUILD b/extra/qt5-webkit/PKGBUILD
new file mode 100644
index 00000000..e651867f
--- /dev/null
+++ b/extra/qt5-webkit/PKGBUILD
@@ -0,0 +1,6 @@
+# ruby currently not recognized on i486
+# (TODO: but we cannot disable ruby)
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//ruby/})
+fi
+