summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/linux-zen/PKGBUILD6
-rw-r--r--extra/linux-zen/config9
2 files changed, 8 insertions, 7 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 357e9901..dd5279cd 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: 9500b1c1712205e0e5aaa217380617cf22c11a05
+# upstream git revision: 8226c2d9312083f63c5fc1e52b80649ae17062d6
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '6d37347ff115a6edf9d9d2b14fbb5ae62664da1a693670a67198dc4cacf93df4' ]; then
- sha256sums[${i}]='a868b1f159f8c2ef983d0273c3c15adb5f83ae598f1c56f62a59a0ed57380f99'
+ if [ "${sha256sums[${i}]}" = '775e62bef116136f7b258ecc32ad1071dc2c6b161176d78092e29f180136dac9' ]; then
+ sha256sums[${i}]='c1bd1d75927ddf32b3ba8f5f2d47120735180964ccfbc023512bd069c5920111'
fi
done
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index 5da6ea92..ad854cff 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.5.5-zen1 Kernel Configuration
+# Linux/x86 5.5.6-zen1 Kernel Configuration
#
#
@@ -10353,8 +10353,7 @@ CONFIG_FONT_8x16=y
# CONFIG_FONT_10x18 is not set
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set
-# CONFIG_FONT_TER16x32 is not set
-CONFIG_FONT_AUTOSELECT=y
+CONFIG_FONT_TER16x32=y
CONFIG_SG_POOL=y
CONFIG_ARCH_STACKWALK=y
CONFIG_SBITMAP=y
@@ -10420,7 +10419,9 @@ CONFIG_DEBUG_MISC=y
# CONFIG_PAGE_EXTENSION is not set
# CONFIG_DEBUG_PAGEALLOC is not set
# CONFIG_PAGE_OWNER is not set
-# CONFIG_PAGE_POISONING is not set
+CONFIG_PAGE_POISONING=y
+CONFIG_PAGE_POISONING_NO_SANITY=y
+CONFIG_PAGE_POISONING_ZERO=y
# CONFIG_DEBUG_PAGE_REF is not set
# CONFIG_DEBUG_RODATA_TEST is not set
# CONFIG_DEBUG_OBJECTS is not set