summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/binutils/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index 71467e4b..9e9b625c 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -26,6 +26,31 @@ eval "$(
'
)"
+# "configure: error: debuginfod is missing or unusable"
+eval "$(
+ declare -f build | \
+ sed '
+ s/--with-debuginfod//g
+ '
+)"
+
+# should be in a cross-compilation binutils for targeting EFI binaries IMHO,
+# not in the main platform binutils (see also https://bugs.archlinux.org/task/42540)
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-targets=x86_64-pep//g
+ '
+)"
+
+# --enable-64-bit-bfd makes sense only for 64-bit targets IMHO
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-64-bit-bfd//g
+ '
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# disable CET (Control Flow instructions endbr32/enbr64)