summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/libseccomp/PKGBUILD41
-rw-r--r--core/libseccomp/libseccomp-2.4.2-ppoll.patch25
2 files changed, 64 insertions, 2 deletions
diff --git a/core/libseccomp/PKGBUILD b/core/libseccomp/PKGBUILD
index 5c87b62b..36c698ba 100644
--- a/core/libseccomp/PKGBUILD
+++ b/core/libseccomp/PKGBUILD
@@ -19,5 +19,42 @@ if [ "${CARCH}" = "i486" ]; then
)"
fi
-# temporarily, see upstream https://github.com/seccomp/libseccomp/issues/166
-unset check
+# force 2.4.2 version as 2.4.1-4 version to make glibc 2.31 work and
+# make it possible to do proper upgrades afterwards to 2.4.2-1
+source=(https://github.com/seccomp/${pkgname}/releases/download/v2.4.2/${pkgname}-2.4.2.tar.gz)
+pkgrel=4
+sha256sums=(b54f27b53884caacc932e75e6b44304ac83586e2abe7a83eca6daecc5440585b)
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/cd ${pkgname}-${pkgver}/cd libseccomp-2.4.2/
+ '
+)"
+
+eval "$(
+ declare -f check | \
+ sed '
+ s/cd ${pkgname}-${pkgver}/cd libseccomp-2.4.2/
+ '
+)"
+
+eval "$(
+ declare -f package | \
+ sed '
+ s/cd ${pkgname}-${pkgver}/cd libseccomp-2.4.2/
+ '
+)"
+
+source+=('libseccomp-2.4.2-ppoll.patch')
+sha256sums+=('2d6f638428bc7f9931d4e0a59b80f13327d6c3748e7049eba54b0be08f6620a9')
+prepare() {
+ cd ${pkgbase}-2.4.2
+ patch -Np1 -i "$srcdir/libseccomp-2.4.2-ppoll.patch"
+}
+
+# XXX: do NOT trust this key as its not yet in the strong set, see linked issue
+# XXX: https://github.com/seccomp/libseccomp/issues/187
+# XXX: 47A68FCE37C7D7024FD65E11356CE62C2B524099 Tom Hromatka <tom.hromatka@oracle.com>
+# XXX: do NOT trust ^^ this key as its not yet in the strong set ^^ see linked issue
+validpgpkeys=('7100AADFAE6E6E940D2E0AD655E45A5AE8CA7C8A') # Paul Moore <paul@paul-moore.com>
diff --git a/core/libseccomp/libseccomp-2.4.2-ppoll.patch b/core/libseccomp/libseccomp-2.4.2-ppoll.patch
new file mode 100644
index 00000000..884afb8a
--- /dev/null
+++ b/core/libseccomp/libseccomp-2.4.2-ppoll.patch
@@ -0,0 +1,25 @@
+diff --git a/include/seccomp-syscalls.h b/include/seccomp-syscalls.h
+index 6457592..3c958df 100644
+--- a/include/seccomp-syscalls.h
++++ b/include/seccomp-syscalls.h
+@@ -272,6 +272,7 @@
+ #define __PNR_timerfd_gettime64 -10238
+ #define __PNR_timerfd_settime64 -10239
+ #define __PNR_utimensat_time64 -10240
++#define __PNR_ppoll -10241
+
+ /*
+ * libseccomp syscall definitions
+@@ -1359,6 +1360,12 @@
+ #define __SNR_poll __PNR_poll
+ #endif
+
++#ifdef __NR_ppoll
++#define __SNR_ppoll __NR_ppoll
++#else
++#define __SNR_ppoll __PNR_ppoll
++#endif
++
+ #ifdef __NR_ppoll_time64
+ #define __SNR_ppoll_time64 __NR_ppoll_time64
+ #else