summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/sysprof/PKGBUILD8
-rw-r--r--extra/sysprof/sysprof-3.36.0-allocs-by-size-gsize-format.patch12
2 files changed, 20 insertions, 0 deletions
diff --git a/extra/sysprof/PKGBUILD b/extra/sysprof/PKGBUILD
new file mode 100644
index 00000000..de23085b
--- /dev/null
+++ b/extra/sysprof/PKGBUILD
@@ -0,0 +1,8 @@
+source+=('sysprof-3.36.0-allocs-by-size-gsize-format.patch')
+sha256sums+=('cce5ea34047e29327b9a4d127e4db3030c142e43191358d712242383fcba565d')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cd.*/a patch -p1 -i "$srcdir/sysprof-3.36.0-allocs-by-size-gsize-format.patch"
+ '
+)"
diff --git a/extra/sysprof/sysprof-3.36.0-allocs-by-size-gsize-format.patch b/extra/sysprof/sysprof-3.36.0-allocs-by-size-gsize-format.patch
new file mode 100644
index 00000000..831c2f30
--- /dev/null
+++ b/extra/sysprof/sysprof-3.36.0-allocs-by-size-gsize-format.patch
@@ -0,0 +1,12 @@
+diff -rauN sysprof-3.36.0/src/tests/allocs-by-size.c sysprof-3.36.0-allocs-by-size-gsize-format-patch/src/tests/allocs-by-size.c
+--- sysprof-3.36.0/src/tests/allocs-by-size.c 2020-03-22 20:00:12.677048822 +0100
++++ sysprof-3.36.0-allocs-by-size-gsize-format-patch/src/tests/allocs-by-size.c 2020-03-22 20:01:07.000418361 +0100
+@@ -109,7 +109,7 @@
+ {
+ const Item *item = &g_array_index (ar, Item, i);
+
+- g_print ("%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT"\n",
++ g_print ("%"G_GSIZE_FORMAT",%"G_GSIZE_FORMAT",%"G_GSIZE_FORMAT"\n",
+ item->size, item->cmp, item->count);
+ }
+ }