summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/rust/PKGBUILD2
-rw-r--r--extra/rust/config.toml.patch21
2 files changed, 11 insertions, 12 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index e126e525..60d5798b 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('41cb009565b592bcd73dbfbfa53e4462570c85de58b225893e8f1ff25d640a04')
+sha256sums+=('573b9869d71740aa5c7023670926600f5843d6e12480e3c9895caa37a4bc479c')
eval "$(
declare -f prepare | \
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index 1aeb55c1..3f0bf664 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,30 +1,29 @@
diff -rauN a/config.toml b/config.toml
---- a/config.toml 2021-02-04 07:47:59.117133704 +0100
-+++ b/config.toml 2021-02-04 07:50:40.203582394 +0100
-@@ -2,7 +2,7 @@
+--- a/config.toml 2021-07-01 13:11:44.805605461 +0530
++++ b/config.toml 2021-07-01 13:14:42.562880610 +0530
+@@ -5,7 +5,7 @@
link-shared = true
-
+
[build]
-target = ["x86_64-unknown-linux-gnu", "i686-unknown-linux-gnu", "x86_64-unknown-linux-musl"]
+target = ["i686-unknown-linux-gnu", "i686-unknown-linux-musl"]
- tools = ["cargo", "rls", "clippy", "miri", "rustfmt", "analysis", "src"]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
-@@ -22,14 +22,14 @@
+ rustfmt = "/usr/bin/rustfmt"
+@@ -24,13 +24,13 @@
# https://github.com/rust-lang/rust/issues/54872
codegen-units-std = 1
-
+
-debuginfo-level-std = 2
+debuginfo-level-std = 0
-
channel = "stable"
-
rpath = false
-
+
-[target.x86_64-unknown-linux-gnu]
+[target.i686-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"
-
+
-[target.x86_64-unknown-linux-musl]
+[target.i686-unknown-linux-musl]
+ sanitizers = false
musl-root = "/usr/lib/musl"