summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--blacklist1
-rw-r--r--community/firefox-developer-edition/PKGBUILD67
2 files changed, 0 insertions, 68 deletions
diff --git a/blacklist b/blacklist
index 95bce107..968c8aa8 100644
--- a/blacklist
+++ b/blacklist
@@ -4,7 +4,6 @@ i686 cuda # cuda 9.0 is 64-bit only
i686 delve # currently no 32-bit support, see <a href="https://github.com/derekparker/delve/issues/20">upstream</a>
i686 dotnet-core # not available for 32-bit on linux, see <a href="https://github.com/dotnet/core/blob/master/release-notes/download-archives/2.0.5-download.md">here</a>
i686 firefox-developer-edition # llvm segfaults, virtual memory issues (blacklisting may be temporary)
-i586 firefox-developer-edition # llvm segfaults, virtual memory issues, missing rust (blacklisting may be temporary)
i686 linux-hardened # not <a href="https://mirror.archlinux32.org/irc-logs/%23archlinux-ports/2017-06-28.html#04:04:01">really useful</a> on i686 + hard to maintain
i486 linux-pae # not useful - use i686 instead
i686 libretro-citra # do not build, see FS32#23
diff --git a/community/firefox-developer-edition/PKGBUILD b/community/firefox-developer-edition/PKGBUILD
deleted file mode 100644
index 5087c006..00000000
--- a/community/firefox-developer-edition/PKGBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-eval "$(
- declare -f build | \
- sed '
- /cd mozilla-unified/a sed -i "s/\\(cargo_rustc_flags += -C lto\\)/#\\1/" config/rules.mk
- '
- declare -f prepare | \
- sed '
- $ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
- '
-)"
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^?#]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
-
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done