summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/virtualbox/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/community/virtualbox/PKGBUILD b/community/virtualbox/PKGBUILD
index b876bc75..037684be 100644
--- a/community/virtualbox/PKGBUILD
+++ b/community/virtualbox/PKGBUILD
@@ -1,5 +1,15 @@
# set manually sysctl vm.mmap_min_addr=0 before building this package
+# linker runs out of memory on 32-bit
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i LDFLAGS+=" -Wl,--no-keep-memory"
+ 3 i CFLAGS+=" -g1"
+ 3 i CXXFLAGS+=" -g1"
+ '
+)"
+
# Parallel builds lead to "virtual memory exhausted"?
# not sure, if still needed (or in fact, working)
eval "$(