summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/haskell-hslua/PKGBUILD24
1 files changed, 23 insertions, 1 deletions
diff --git a/community/haskell-hslua/PKGBUILD b/community/haskell-hslua/PKGBUILD
index d47e3054..349508b0 100644
--- a/community/haskell-hslua/PKGBUILD
+++ b/community/haskell-hslua/PKGBUILD
@@ -1,4 +1,26 @@
# See https://github.com/jgm/pandoc/issues/4224 and
# https://github.com/jgm/pandoc/issues/3805
-eval "$(declare -f build | sed 's| -f-lua_32bits| -flua_32bits|')"
+eval "$(
+ declare -f build | \
+ sed '
+ s| -f-lua_32bits| -flua_32bits|
+ '
+)"
+
+# this test hangs (why?)
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ 2 a \
+ sed -i '"'"' \
+ /loadfile loading/ { \
+ :a \
+ /^.*\\n$/d \
+ N \
+ ba \
+ } \
+ '"'"' "$_hkgname-$pkgver/test/Foreign/Lua/ApiTest.hs"
+ '
+)"