summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/btrfs-progs/FS#58237.patch16
-rw-r--r--core/btrfs-progs/PKGBUILD0
2 files changed, 16 insertions, 0 deletions
diff --git a/core/btrfs-progs/FS#58237.patch b/core/btrfs-progs/FS#58237.patch
new file mode 100644
index 00000000..21a11fc3
--- /dev/null
+++ b/core/btrfs-progs/FS#58237.patch
@@ -0,0 +1,16 @@
+diff --git a/utils.c b/utils.c
+index e9cb3a82f..f867e5a7f 100644
+--- a/utils.c
++++ b/utils.c
+@@ -2484,11 +2484,6 @@ const char *subvol_strip_mountpoint(const char *mnt, const char *full_path)
+ if (!len)
+ return full_path;
+
+- if ((strncmp(mnt, full_path, len) != 0) || (full_path[len] != '/')) {
+- error("not on mount point: %s", mnt);
+- exit(1);
+- }
+-
+ if (mnt[len - 1] != '/')
+ len += 1;
+
diff --git a/core/btrfs-progs/PKGBUILD b/core/btrfs-progs/PKGBUILD
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/core/btrfs-progs/PKGBUILD