summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/make/FS55127.patch26
-rw-r--r--core/make/PKGBUILD8
2 files changed, 34 insertions, 0 deletions
diff --git a/core/make/FS55127.patch b/core/make/FS55127.patch
new file mode 100644
index 00000000..9b5291cc
--- /dev/null
+++ b/core/make/FS55127.patch
@@ -0,0 +1,26 @@
+From d9d4e06084a4c7da480bd49a3487aadf6ba77b54 Mon Sep 17 00:00:00 2001
+From: Enrique Olaizola <enrique_olaizola16@hotmail.com>
+Date: Sat, 27 May 2017 14:24:33 -0400
+Subject: * tests/run_make_tests.pl: [SV 50902] Find Perl modules
+
+---
+ tests/run_make_tests.pl | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/run_make_tests.pl b/tests/run_make_tests.pl
+index a74417a..a844094 100644
+--- a/tests/run_make_tests.pl
++++ b/tests/run_make_tests.pl
+@@ -64,6 +64,9 @@ if ($^O eq 'VMS')
+ $CMD_rmfile = 'delete_file -no_ask';
+ }
+
++use FindBin;
++use lib "$FindBin::Bin";
++
+ require "test_driver.pl";
+ require "config-flags.pm";
+
+--
+cgit v1.0-41-gc330
+
diff --git a/core/make/PKGBUILD b/core/make/PKGBUILD
new file mode 100644
index 00000000..4be2e8bb
--- /dev/null
+++ b/core/make/PKGBUILD
@@ -0,0 +1,8 @@
+source+=('FS55127.patch')
+md5sums+=('8efba0d7ff90f5394edda0f83259af05')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /^\s*cd\s/a patch -p1 -i ${srcdir}/FS55127.patch
+ '
+)"