summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-07-05 10:09:17 +0200
committerErich Eckner <git@eckner.net>2019-07-05 10:09:17 +0200
commitfe1931a16e36d1f544c04f0229758ddba1884462 (patch)
tree516f6c55a0001a9d772bbba12baac4b7f1377094 /extra
parent57414235d1cdd9643c70b45283f84106e41c8f10 (diff)
downloadpackages-fe1931a16e36d1f544c04f0229758ddba1884462.tar.xz
extra/libgit2: remove patch - it does not apply and the package builds fine without it
Diffstat (limited to 'extra')
-rw-r--r--extra/libgit2/PKGBUILD10
-rw-r--r--extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch21
2 files changed, 0 insertions, 31 deletions
diff --git a/extra/libgit2/PKGBUILD b/extra/libgit2/PKGBUILD
deleted file mode 100644
index 87d81bff..00000000
--- a/extra/libgit2/PKGBUILD
+++ /dev/null
@@ -1,10 +0,0 @@
-# see also Gentoo, disable the TOOBIG test
-# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=99914da67e748f4eceec5a02e9ce603917d50004
-
-source+=('libgit2-0.27.7-disable-oom-tests-on-32bit.patch')
-sha256sums+=('2feabf58c149fb0c55f00d389f66c71a56ab90c7ae2fc492f8a06ec64765cbef')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 -i ../libgit2-0.27.7-disable-oom-tests-on-32bit.patch
-}
diff --git a/extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch b/extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch
deleted file mode 100644
index 918e22ec..00000000
--- a/extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -rauN libgit2-0.27.7/tests/buf/oom.c libgit2-0.27.7-disable-oom-tests-on-32bit-patch/tests/buf/oom.c
---- libgit2-0.27.7/tests/buf/oom.c 2018-10-26 15:27:21.000000000 +0200
-+++ libgit2-0.27.7-disable-oom-tests-on-32bit-patch/tests/buf/oom.c 2018-11-09 15:17:30.475788525 +0100
-@@ -32,6 +32,7 @@
- */
- void test_buf_oom__grow(void)
- {
-+#if defined(GIT_ARCH_64)
- git_buf buf = GIT_BUF_INIT;
-
- git_buf_clear(&buf);
-@@ -40,6 +41,9 @@
- cl_assert(git_buf_oom(&buf));
-
- git_buf_free(&buf);
-+#else
-+ cl_skip();
-+#endif
- }
-
- void test_buf_oom__grow_by(void)