summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-05-20 11:25:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-05-20 11:25:59 +0200
commitf31bad7e31f6728af66a8f85cddc6634409acfdf (patch)
tree1e418647ba066af1a2b840a7a391518dff605325 /extra
parent7ca76f3fc7b5fcc551147e3a2a3b0e8975a082e7 (diff)
downloadpackages-f31bad7e31f6728af66a8f85cddc6634409acfdf.tar.xz
extra/mplayer: patch for sigcontext still needed, why does it fail!?!
Diffstat (limited to 'extra')
-rw-r--r--extra/mplayer/PKGBUILD9
-rw-r--r--extra/mplayer/mplayer-38101-sigcontext.patch11
2 files changed, 20 insertions, 0 deletions
diff --git a/extra/mplayer/PKGBUILD b/extra/mplayer/PKGBUILD
new file mode 100644
index 00000000..eea2ca1a
--- /dev/null
+++ b/extra/mplayer/PKGBUILD
@@ -0,0 +1,9 @@
+source+=(mplayer-38101-sigcontext.patch)
+sha512sums+=('2f93d29f1d817a64104cad7153988583443932e6bb6d147747a1af5c7a76d24da0f3305466d43e803012dd31d89cb17e8c7cb7b19d2896165fa74cc06da346e0')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch/a patch -Np1 -i ../mplayer-38101-sigcontext.patch
+ '
+)"
diff --git a/extra/mplayer/mplayer-38101-sigcontext.patch b/extra/mplayer/mplayer-38101-sigcontext.patch
new file mode 100644
index 00000000..31e2d4c8
--- /dev/null
+++ b/extra/mplayer/mplayer-38101-sigcontext.patch
@@ -0,0 +1,11 @@
+diff -rauN mplayer-38101/cpudetect.c mplayer-38101-sigcontext-patch/cpudetect.c
+--- mplayer-38101/cpudetect.c 2018-05-17 11:15:24.975263641 +0200
++++ mplayer-38101-sigcontext-patch/cpudetect.c 2018-05-17 12:04:52.811930307 +0200
+@@ -38,6 +38,7 @@
+ #include <sys/types.h>
+ #include <sys/sysctl.h>
+ #elif defined(__linux__)
++#define __USE_MISC // for struct struct sigcontext
+ #include <signal.h>
+ #elif defined(__MINGW32__) || defined(__CYGWIN__)
+ #include <windows.h>