summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-09 19:16:00 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-09 19:16:00 +0200
commite3b73e39b4c26b5f31b1d2b0603b41e20e156856 (patch)
treec38d9661bd489059ba2666736db9574f2fe1c163 /extra
parentf3627088e82d4d6c1b097d5949368ca7bdc28016 (diff)
downloadpackages-e3b73e39b4c26b5f31b1d2b0603b41e20e156856.tar.xz
extra/webkit2gtk: added flags to minimize memory usage when linking
Diffstat (limited to 'extra')
-rw-r--r--extra/webkit2gtk/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index 4c4fb0aa..6919b547 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -28,3 +28,13 @@ eval "$(
}
'
)"
+
+# linker runs out of memory on 32-bit
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i LDFLAGS+=" -Wl,--no-keep-memory"
+ 3 i CFLAGS+=" -g1"
+ 3 i CXXFLAGS+=" -g1"
+ '
+)"