summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-10 11:04:44 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-10 11:04:44 +0200
commitdc9801c05d018acac477f2db3e497c57fc978f39 (patch)
tree110da99265fb36f22cba6b489b3238044a2dd1dd /extra
parent711af449afd9bc446ab0bf9f858e09736c296b24 (diff)
downloadpackages-dc9801c05d018acac477f2db3e497c57fc978f39.tar.xz
extra/ibus: i486 build with no vala, gtk3, qt5-base
Diffstat (limited to 'extra')
-rw-r--r--extra/ibus/PKGBUILD27
-rw-r--r--extra/ibus/ibus-novala.patch53
2 files changed, 80 insertions, 0 deletions
diff --git a/extra/ibus/PKGBUILD b/extra/ibus/PKGBUILD
new file mode 100644
index 00000000..f533da4a
--- /dev/null
+++ b/extra/ibus/PKGBUILD
@@ -0,0 +1,27 @@
+# break cycle with Qt, gtk3 on i486
+# Vala is not bootstrapped on i486
+# disable wayland for now
+if [ "$CARCH" = 'i486' ]; then
+ depends=(${depends[@]//gtk3/})
+ makedepends=(${makedepends[@]//qt5-base/})
+ makedepends=(${makedepends[@]//vala/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@./configure --disable-gtk3 --enable-vala=no --disable-engine --disable-tools@
+ s@--enable-wayland@--disable-wayland@
+ '
+ )"
+
+ # some parts of the engine and the tools still require Vala
+ source+=('ibus-novala.patch')
+ sha512sums+=('4618394f118e67e340831beb71929bed06be4335d2e0e8ce9793459cf19b0bf0255f7757471433036a362b8beb63f12e79832e40b98435e4209bbe04d590b070')
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /cd/ a \
+ patch -Np1 -i "$srcdir/ibus-novala.patch"
+ '
+ )"
+fi
diff --git a/extra/ibus/ibus-novala.patch b/extra/ibus/ibus-novala.patch
new file mode 100644
index 00000000..0619f02b
--- /dev/null
+++ b/extra/ibus/ibus-novala.patch
@@ -0,0 +1,53 @@
+diff -rauN ibus/configure.ac ibus-novala-patch/configure.ac
+--- ibus/configure.ac 2021-04-10 10:53:19.694774398 +0200
++++ ibus-novala-patch/configure.ac 2021-04-10 10:54:26.574743698 +0200
+@@ -611,6 +611,18 @@
+ enable_engine="yes (enabled, use --disable-engine to disable)"
+ fi
+
++# --disable-tools
++AC_ARG_ENABLE(tools,
++ AS_HELP_STRING([--disable-tools],
++ [Disable tools]),
++ [enable_tools=$enableval],
++ [enable_tools=yes]
++)
++AM_CONDITIONAL([ENABLE_TOOLS], [test x"$enable_tools" = x"yes"])
++if test x"$enable_tools" = x"yes"; then
++ enable_tools="yes (enabled, use --disable-tools to disable)"
++fi
++
+ PKG_CHECK_MODULES(XTEST,
+ [x11 xtst],
+ [enable_xtest=yes],
+@@ -833,6 +845,7 @@
+ Build document $enable_gtk_doc
+ Build UI $enable_ui
+ Build engine $enable_engine
++ Build tools $enable_tools
+ Enable key snooper $enable_key_snooper
+ No snooper regexes "$NO_SNOOPER_APPS"
+ Panel icon "$IBUS_ICON_KEYBOARD"
+diff -rauN ibus/Makefile.am ibus-novala-patch/Makefile.am
+--- ibus/Makefile.am 2021-04-10 10:53:19.688107734 +0200
++++ ibus-novala-patch/Makefile.am 2021-04-10 10:54:21.234746577 +0200
+@@ -31,6 +31,10 @@
+ ENGINE_DIR = engine
+ endif
+
++if ENABLE_TOOLS
++TOOLS_DIR = tools
++endif
++
+ if ENABLE_SETUP
+ SETUP_DIR = setup
+ endif
+@@ -58,7 +62,7 @@
+ docs \
+ $(ENGINE_DIR) \
+ $(UI_DIR) \
+- tools \
++ $(TOOLS_DIR) \
+ $(DAEMON_DIR) \
+ $(PYTHON_LIB_DIRS) \
+ $(SETUP_DIR) \