summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-11-09 15:51:52 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2018-11-09 15:51:52 +0100
commitd2b638674f3c14e77568c33672da0e13cf0d7cf9 (patch)
tree496b71257ffb507633ef7d2598864c89324f0cb6 /extra
parentb1ee02b9f16cd9b7c3f254193c005a14acb02cf0 (diff)
downloadpackages-d2b638674f3c14e77568c33672da0e13cf0d7cf9.tar.xz
extra/libgit2: skipping OOM tests
Diffstat (limited to 'extra')
-rw-r--r--extra/libgit2/PKGBUILD10
-rw-r--r--extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch21
2 files changed, 31 insertions, 0 deletions
diff --git a/extra/libgit2/PKGBUILD b/extra/libgit2/PKGBUILD
new file mode 100644
index 00000000..87d81bff
--- /dev/null
+++ b/extra/libgit2/PKGBUILD
@@ -0,0 +1,10 @@
+# see also Gentoo, disable the TOOBIG test
+# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=99914da67e748f4eceec5a02e9ce603917d50004
+
+source+=('libgit2-0.27.7-disable-oom-tests-on-32bit.patch')
+sha256sums+=('2feabf58c149fb0c55f00d389f66c71a56ab90c7ae2fc492f8a06ec64765cbef')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i ../libgit2-0.27.7-disable-oom-tests-on-32bit.patch
+}
diff --git a/extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch b/extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch
new file mode 100644
index 00000000..918e22ec
--- /dev/null
+++ b/extra/libgit2/libgit2-0.27.7-disable-oom-tests-on-32bit.patch
@@ -0,0 +1,21 @@
+diff -rauN libgit2-0.27.7/tests/buf/oom.c libgit2-0.27.7-disable-oom-tests-on-32bit-patch/tests/buf/oom.c
+--- libgit2-0.27.7/tests/buf/oom.c 2018-10-26 15:27:21.000000000 +0200
++++ libgit2-0.27.7-disable-oom-tests-on-32bit-patch/tests/buf/oom.c 2018-11-09 15:17:30.475788525 +0100
+@@ -32,6 +32,7 @@
+ */
+ void test_buf_oom__grow(void)
+ {
++#if defined(GIT_ARCH_64)
+ git_buf buf = GIT_BUF_INIT;
+
+ git_buf_clear(&buf);
+@@ -40,6 +41,9 @@
+ cl_assert(git_buf_oom(&buf));
+
+ git_buf_free(&buf);
++#else
++ cl_skip();
++#endif
+ }
+
+ void test_buf_oom__grow_by(void)