summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-11 10:31:09 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-11 10:31:09 +0100
commit8972a2f85a6d09d29b6e107d8e68b4422a880f22 (patch)
tree2028021b8f95f246eb138d48ad7bb52214249266 /extra
parent757e1ca30cde7a11f7a08e77795e48e7959529fc (diff)
downloadpackages-8972a2f85a6d09d29b6e107d8e68b4422a880f22.tar.xz
extra/meson: tried to fix testing a little bit
Diffstat (limited to 'extra')
-rw-r--r--extra/meson/PKGBUILD17
1 files changed, 16 insertions, 1 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index a2d42e6e..0f009bb1 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -1,3 +1,18 @@
-# checks fail in various ways (also upstream)
+# we have no 32-bit cuda support
+checkdepends=(${checkdepends[@]//cuda/})
+
+# no rust on i486
+checkdepends=(${checkdepends[@]//rust-bindgen/})
+checkdepends=(${checkdepends[@]//rust/})
+checkdepends_i686+=('rust')
+checkdepends_i686+=('rust-bindgen')
+
+# D compiler broken on i486
+checkdepends=(${checkdepends[@]//ldc/})
+checkdepends_i686+=('ldc')
+
+checkdepends_pentium4=("${checkdepends_i686[@]}")
+
+# still far too many tests fail, ignoring for now
unset check
unset checkdepends