summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-10-25 09:56:48 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-10-25 09:56:48 +0200
commit77a5faaa6ea7f89e6866424e4012884d8e0fb3fe (patch)
tree1ecee8a8296242370b0bb2c6c22a82c7b87f15de /extra
parent705ee6cd0d0d092abf83aa1b01104d3ccccd31f1 (diff)
downloadpackages-77a5faaa6ea7f89e6866424e4012884d8e0fb3fe.tar.xz
extra/libgit2: removed patch for _FILE_OFFSET_BITS=64 in test cmakefile
Diffstat (limited to 'extra')
-rw-r--r--extra/libgit2/PKGBUILD9
-rw-r--r--extra/libgit2/libgit2-ssp-offset64-stat-buf.patch12
2 files changed, 0 insertions, 21 deletions
diff --git a/extra/libgit2/PKGBUILD b/extra/libgit2/PKGBUILD
deleted file mode 100644
index e0b17681..00000000
--- a/extra/libgit2/PKGBUILD
+++ /dev/null
@@ -1,9 +0,0 @@
-# See: https://github.com/libgit2/libgit2/pull/4631
-
-source+=('libgit2-ssp-offset64-stat-buf.patch')
-sha256sums+=('4eceeb944c7ea2dd2f879a279d5eb0f80ae32675410a6601bcc07ccd0189e8cf')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i "$srcdir/libgit2-ssp-offset64-stat-buf.patch"
-}
diff --git a/extra/libgit2/libgit2-ssp-offset64-stat-buf.patch b/extra/libgit2/libgit2-ssp-offset64-stat-buf.patch
deleted file mode 100644
index a6ee91d9..00000000
--- a/extra/libgit2/libgit2-ssp-offset64-stat-buf.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 775f33f2d..e73e7237c 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -9,6 +9,7 @@ SET(CLAR_FIXTURES "${CMAKE_CURRENT_SOURCE_DIR}/resources/")
- SET(CLAR_PATH "${CMAKE_CURRENT_SOURCE_DIR}")
- ADD_DEFINITIONS(-DCLAR_FIXTURE_PATH=\"${CLAR_FIXTURES}\")
- ADD_DEFINITIONS(-DCLAR_TMPDIR=\"libgit2_tests\")
-+ADD_DEFINITIONS(-D_FILE_OFFSET_BITS=64)
-
- INCLUDE_DIRECTORIES(${CLAR_PATH} ${libgit2_BINARY_DIR}/src)
- FILE(GLOB_RECURSE SRC_TEST ${CLAR_PATH}/*/*.c ${CLAR_PATH}/*/*.h)