summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-10-16 13:23:22 +0200
committerErich Eckner <git@eckner.net>2018-10-16 13:23:22 +0200
commit71ad3d47af4e9b125d6cb15298ad5977addf4520 (patch)
tree7c054d6604c91b65c25d9575cf92f674317ebc82 /extra
parente83615201d332af851af51937b4f90ea279855cc (diff)
downloadpackages-71ad3d47af4e9b125d6cb15298ad5977addf4520.tar.xz
extra/aspell: add temporary patch
Diffstat (limited to 'extra')
-rw-r--r--extra/aspell/8089fa02122fed0a6394eba14bbedcb1d18e2384.patch37
-rw-r--r--extra/aspell/PKGBUILD9
2 files changed, 46 insertions, 0 deletions
diff --git a/extra/aspell/8089fa02122fed0a6394eba14bbedcb1d18e2384.patch b/extra/aspell/8089fa02122fed0a6394eba14bbedcb1d18e2384.patch
new file mode 100644
index 00000000..61ffabba
--- /dev/null
+++ b/extra/aspell/8089fa02122fed0a6394eba14bbedcb1d18e2384.patch
@@ -0,0 +1,37 @@
+From 8089fa02122fed0a6394eba14bbedcb1d18e2384 Mon Sep 17 00:00:00 2001
+From: Kevin Atkinson <kevina@gnu.org>
+Date: Thu, 29 Dec 2016 00:50:31 -0500
+Subject: [PATCH] Compile Fixes for GCC 7.
+
+Closes #519.
+---
+ modules/filter/tex.cpp | 2 +-
+ prog/check_funs.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
+index a979539..19ab63c 100644
+--- a/modules/filter/tex.cpp
++++ b/modules/filter/tex.cpp
+@@ -174,7 +174,7 @@ namespace {
+
+ if (c == '{') {
+
+- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
++ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
+ push_command(Parm);
+
+ top.in_what = Parm;
+diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
+index db54f3d..89ee09d 100644
+--- a/prog/check_funs.cpp
++++ b/prog/check_funs.cpp
+@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
+ }
+ }
+ if (i == width-1) {
+- if (word == '\0')
++ if (*word == '\0')
+ put(out,' ');
+ else if (word[len] == '\0')
+ put(out, word, len);
diff --git a/extra/aspell/PKGBUILD b/extra/aspell/PKGBUILD
new file mode 100644
index 00000000..76302bd6
--- /dev/null
+++ b/extra/aspell/PKGBUILD
@@ -0,0 +1,9 @@
+# see https://github.com/GNUAspell/aspell/issues/519
+source+=('8089fa02122fed0a6394eba14bbedcb1d18e2384.patch')
+md5sums+=('5f81982bf5ba10d8f23e8086dfcca867')
+sha1sums+=('df5364a8472154452f4e1fe9db0891df457949e0')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/8089fa02122fed0a6394eba14bbedcb1d18e2384.patch"
+}