summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-13 21:35:49 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-13 21:35:49 +0200
commit586119e0f475fb994d42f0ac45dee6b8f71591ef (patch)
treeb6654605193958baa9b9acd58ccbf0dc8b5a8a03 /extra
parent5fe14be61832d223ec78a2febb2530ec5420c8f5 (diff)
downloadpackages-586119e0f475fb994d42f0ac45dee6b8f71591ef.tar.xz
extra/ibus: readded vala on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/ibus/PKGBUILD24
-rw-r--r--extra/ibus/ibus-novala.patch53
2 files changed, 0 insertions, 77 deletions
diff --git a/extra/ibus/PKGBUILD b/extra/ibus/PKGBUILD
deleted file mode 100644
index 59ad3490..00000000
--- a/extra/ibus/PKGBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
-# Vala is not bootstrapped on i486
-# disable wayland for now
-if [ "$CARCH" = 'i486' ]; then
- makedepends=(${makedepends[@]//vala/})
- eval "$(
- declare -f build | \
- sed '
- s@./configure@./configure --disable-gtk3 --enable-vala=no --disable-engine --disable-tools@
- s@--enable-wayland@--disable-wayland@
- '
- )"
-
- # some parts of the engine and the tools still require Vala
- source+=('ibus-novala.patch')
- sha512sums+=('4618394f118e67e340831beb71929bed06be4335d2e0e8ce9793459cf19b0bf0255f7757471433036a362b8beb63f12e79832e40b98435e4209bbe04d590b070')
-
- eval "$(
- declare -f prepare | \
- sed '
- /cd/ a \
- patch -Np1 -i "$srcdir/ibus-novala.patch"
- '
- )"
-fi
diff --git a/extra/ibus/ibus-novala.patch b/extra/ibus/ibus-novala.patch
deleted file mode 100644
index 0619f02b..00000000
--- a/extra/ibus/ibus-novala.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -rauN ibus/configure.ac ibus-novala-patch/configure.ac
---- ibus/configure.ac 2021-04-10 10:53:19.694774398 +0200
-+++ ibus-novala-patch/configure.ac 2021-04-10 10:54:26.574743698 +0200
-@@ -611,6 +611,18 @@
- enable_engine="yes (enabled, use --disable-engine to disable)"
- fi
-
-+# --disable-tools
-+AC_ARG_ENABLE(tools,
-+ AS_HELP_STRING([--disable-tools],
-+ [Disable tools]),
-+ [enable_tools=$enableval],
-+ [enable_tools=yes]
-+)
-+AM_CONDITIONAL([ENABLE_TOOLS], [test x"$enable_tools" = x"yes"])
-+if test x"$enable_tools" = x"yes"; then
-+ enable_tools="yes (enabled, use --disable-tools to disable)"
-+fi
-+
- PKG_CHECK_MODULES(XTEST,
- [x11 xtst],
- [enable_xtest=yes],
-@@ -833,6 +845,7 @@
- Build document $enable_gtk_doc
- Build UI $enable_ui
- Build engine $enable_engine
-+ Build tools $enable_tools
- Enable key snooper $enable_key_snooper
- No snooper regexes "$NO_SNOOPER_APPS"
- Panel icon "$IBUS_ICON_KEYBOARD"
-diff -rauN ibus/Makefile.am ibus-novala-patch/Makefile.am
---- ibus/Makefile.am 2021-04-10 10:53:19.688107734 +0200
-+++ ibus-novala-patch/Makefile.am 2021-04-10 10:54:21.234746577 +0200
-@@ -31,6 +31,10 @@
- ENGINE_DIR = engine
- endif
-
-+if ENABLE_TOOLS
-+TOOLS_DIR = tools
-+endif
-+
- if ENABLE_SETUP
- SETUP_DIR = setup
- endif
-@@ -58,7 +62,7 @@
- docs \
- $(ENGINE_DIR) \
- $(UI_DIR) \
-- tools \
-+ $(TOOLS_DIR) \
- $(DAEMON_DIR) \
- $(PYTHON_LIB_DIRS) \
- $(SETUP_DIR) \