summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-22 14:00:39 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-22 14:00:39 +0200
commit5651f9ad71392a579e210d9aa24ac1478a8a8bf6 (patch)
treee037fc430dbc80fd0d04b1bd98b6a996c320e47d /extra
parent196b8baf3d37a24506259c751f0d5f72a7062e44 (diff)
downloadpackages-5651f9ad71392a579e210d9aa24ac1478a8a8bf6.tar.xz
extra/librsvg: disabled specific optimizations for pentium4, they just fail, rebuild with rust 1.60
Diffstat (limited to 'extra')
-rw-r--r--extra/librsvg/PKGBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/extra/librsvg/PKGBUILD b/extra/librsvg/PKGBUILD
index cd6cb47c..764a52d0 100644
--- a/extra/librsvg/PKGBUILD
+++ b/extra/librsvg/PKGBUILD
@@ -1,5 +1,7 @@
-# target Pentium 3 without SSE2
-if [ "$CARCH" = 'i686' ]; then
+# i686: target Pentium 3 without SSE2
+# pentium4: target pentium3 with SSE2 (disabled as it fails hapilly in
+# microoptimizations for now)
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'pentium4' ]; then
eval "$(
declare -f prepare | \
sed '
@@ -7,21 +9,12 @@ if [ "$CARCH" = 'i686' ]; then
'
)"
fi
-# pentium4: target pentium3 with SSE2
-if [ "$CARCH" = 'pentium4' ]; then
- eval "$(
- declare -f prepare | \
- sed '
- /autogen.sh/ i sed -i \"s/\\\$(CARGO).* build/RUSTFLAGS=\\"-C target-cpu=pentium3\\" \\0/g\" Makefile.am
- '
- )"
-fi
# do not kill slaves with massive parallel rust builds
eval "$(
declare -f build | \
sed '
- s/make/make V=1/
+ s/make/make -j1/
'
)"
@@ -34,6 +27,3 @@ eval "$(
s/make check/make check || true/
'
)"
-
-# temporary to make it build with rust and LLVM12
-makedepends+=(llvm12-libs)