summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-04-28 19:42:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-04-28 19:42:51 +0200
commit49ed1ee4ecdec860b7c8efba6317f31663015e42 (patch)
treeecd62805a8380c0513d89d4afcc853240b90c42d /extra
parent181a6f7383d631e3c54321db4e742992cab4a4b5 (diff)
downloadpackages-49ed1ee4ecdec860b7c8efba6317f31663015e42.tar.xz
extra/ghostscript: breaking gtk3, OpenGL and X cycles
Diffstat (limited to 'extra')
-rw-r--r--extra/ghostscript/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/extra/ghostscript/PKGBUILD b/extra/ghostscript/PKGBUILD
new file mode 100644
index 00000000..cbae39fe
--- /dev/null
+++ b/extra/ghostscript/PKGBUILD
@@ -0,0 +1,22 @@
+# breaking cycle with gtk3 on i486
+makedepends=(${makedepends[@]//gtk3/})
+makedepends_i686+=(gtk3)
+makedepends_pentium4=("${makedepends_i686[@]}")
+
+# breaking cycle with OpenGL on i486
+makedepends=(${makedepends[@]//freeglut/})
+makedepends_i686+=(freeglut)
+makedepends_pentium4=("${makedepends_i686[@]}")
+makedepends=(${makedepends[@]//glu/})
+makedepends_i686+=(glu)
+makedepends_pentium4=("${makedepends_i686[@]}")
+
+# breaking cycle with X
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--with-x/--without-x/g
+ '
+ )"
+fi