summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-02 11:32:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-02 11:32:07 +0200
commit47f5b4ad57608951431b788ec74e90e1df955f46 (patch)
tree6c7087062bf3dabfbba9fdb246076e45b6204a82 /extra
parente338901c75b70f4cc62d40503449b316785e319d (diff)
downloadpackages-47f5b4ad57608951431b788ec74e90e1df955f46.tar.xz
extra/opencolorio: some SSE patching for i686/i486
Diffstat (limited to 'extra')
-rw-r--r--extra/flac/PKGBUILD14
-rw-r--r--extra/opencolorio/PKGBUILD16
2 files changed, 24 insertions, 6 deletions
diff --git a/extra/flac/PKGBUILD b/extra/flac/PKGBUILD
index 76e5bdc2..c266c030 100644
--- a/extra/flac/PKGBUILD
+++ b/extra/flac/PKGBUILD
@@ -15,9 +15,11 @@ eval "$(
)"
# disable SSE on i686 and i486
-eval "$(
- declare -f build | \
- sed '
- s/cmake -S/cmake -DWITH_SSE=OFF -S/
- '
-)"
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/cmake -S/cmake -DWITH_SSE=OFF -S/
+ '
+ )"
+fi
diff --git a/extra/opencolorio/PKGBUILD b/extra/opencolorio/PKGBUILD
index e69de29b..7d8f94cf 100644
--- a/extra/opencolorio/PKGBUILD
+++ b/extra/opencolorio/PKGBUILD
@@ -0,0 +1,16 @@
+# Disable SSE2 in the cmake probing (we cannot set it from outside, so
+# cross-compilation or building in a chrooted environment fails)
+source+=('OpenColorIO-2.1.1-no-sse2.patch')
+sha512sums+=('8055b90d387e2cd674a25344b520d093ef8f761f294a77c71694f7ba93806a58350140b7e373e91432d555def5addd35fad4aca59518aab12b56c5b6106c4352')
+if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
+ eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "$srcdir/OpenColorIO-$pkgver" \
+ patch -Np1 -i "$srcdir/OpenColorIO-2.1.1-no-sse2.patch"
+ '
+ )"
+fi