summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-11-26 20:19:06 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-11-26 20:19:06 +0100
commit30924bdf6e033bba8fa5394ae079fc1e2c48c1c7 (patch)
treea441ff98a3349c3dc8c5a429a49672bf22c2a1d5 /extra
parent3da417806d0b0042c5c65bc06e383c724033e870 (diff)
downloadpackages-30924bdf6e033bba8fa5394ae079fc1e2c48c1c7.tar.xz
extra/libotf: fix for freetype-config -> pkgconf (FS#60427)
Diffstat (limited to 'extra')
-rw-r--r--extra/libotf/PKGBUILD11
-rw-r--r--extra/libotf/libotf-0.9.16-pkgconf.patch31
2 files changed, 42 insertions, 0 deletions
diff --git a/extra/libotf/PKGBUILD b/extra/libotf/PKGBUILD
new file mode 100644
index 00000000..b47c2d89
--- /dev/null
+++ b/extra/libotf/PKGBUILD
@@ -0,0 +1,11 @@
+# freetype-config -> pgconf freetype2 (see FS#60427)
+source+=('libotf-0.9.16-pkgconf.patch')
+sha256sums+=('7bf1eb5aef0f49690fc883a5888925cdf1cf87725b06e5edc696dec8fd3c1428')
+
+eval "$(
+ declare -f build | \
+ sed '
+ /cd.*/a patch -p1 < ../libotf-0.9.16-pkgconf.patch
+ /configure/i ./autogen.sh
+ '
+)"
diff --git a/extra/libotf/libotf-0.9.16-pkgconf.patch b/extra/libotf/libotf-0.9.16-pkgconf.patch
new file mode 100644
index 00000000..36115bb3
--- /dev/null
+++ b/extra/libotf/libotf-0.9.16-pkgconf.patch
@@ -0,0 +1,31 @@
+diff -rauN libotf-0.9.16/configure.ac libotf-0.9.16-pkgconf-patch/configure.ac
+--- libotf-0.9.16/configure.ac 2018-01-24 00:01:37.000000000 +0100
++++ libotf-0.9.16-pkgconf-patch/configure.ac 2019-11-26 20:06:12.782289945 +0100
+@@ -50,13 +50,24 @@
+
+ # Check for Freetype2 usability.
+ AC_CHECK_PROG(HAVE_FREETYPE_CONFIG, freetype-config, yes)
+-if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
+- FREETYPE_INC=`freetype-config --cflags`
++AC_CHECK_PROG(HAVE_PKGCONF, pkgconf, yes)
++if test "x$HAVE_FREETYPE_CONFIG" = "xyes" -o "x$HAVE_PKGCONF" = "xyes"; then
++ if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
++ FREETYPE_INC=`freetype-config --cflags`
++ fi
++ if test "x$HAVE_PKGCONF" = "xyes"; then
++ FREETYPE_INC=`pkgconf --cflags freetype2`
++ fi
+ CPPFLAGS="$CPPFLAGS $FREETYPE_INC"
+ AC_CHECK_HEADER(ft2build.h, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no CPPFLAGS=$save_CPPFLAGS)
+ if test "x$HAVE_FREETYPE" = "xyes" ; then
+- FREETYPE_LD_FLAGS=`freetype-config --libs`;
++ if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
++ FREETYPE_LD_FLAGS=`freetype-config --libs`;
++ fi
++ if test "x$HAVE_PKGCONF" = "xyes"; then
++ FREETYPE_LD_FLAGS=`pkgconf --libs freetype2`;
++ fi
+ LIBS="$LIBS $FREETYPE_LD_FLAGS"
+ AC_CHECK_LIB(freetype, FT_Init_FreeType, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no)