summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-10 14:56:36 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-10 14:56:36 +0200
commit2a88e6bdb9952d1e96a30a16217ccb60fcf0b2f7 (patch)
tree246cc7053155a85ca40e4289d2b0928f3f5f27ff /extra
parent69f5f7e973c260b79a9b67a2baf99842ec7654a2 (diff)
downloadpackages-2a88e6bdb9952d1e96a30a16217ccb60fcf0b2f7.tar.xz
extra/ffmpeg: ignoring rav1e on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/ffmpeg/PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/extra/ffmpeg/PKGBUILD b/extra/ffmpeg/PKGBUILD
index be7aebbe..a2634b99 100644
--- a/extra/ffmpeg/PKGBUILD
+++ b/extra/ffmpeg/PKGBUILD
@@ -46,17 +46,13 @@ if [ "$CARCH" == 'i486' ]; then
)"
fi
-# still required dependencies on i486:
-# sdl2
-# - ibus
-# - gtk3
-# - libnotify
-# - python-gobject
-# - gtk2
-# - qt5-base
-# - unicode-cldr
-# - fcitx
-# v4l-utils
-# - qt5-base
-# - mariadb-libs
-# - qtk3
+# no rav1e on i486, no Rust (yet)
+if [ "$CARCH" == 'i486' ]; then
+ depends=(${depends[@]//librav1e.so/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-librav1e@--disable-librav1e@
+ '
+ )"
+fi