summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-02 22:39:29 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-02 22:39:29 +0200
commit0ab907e642c24e7f776dabed8f76070955ac506e (patch)
treef914f13bbb31b9e677d02edccbbc79484fdb96b8 /extra
parent13b2d005204c0ef9f7468c5a34c81ddd81d628b0 (diff)
downloadpackages-0ab907e642c24e7f776dabed8f76070955ac506e.tar.xz
extra/libinput: break cycle with gtk3 on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/libinput/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/libinput/PKGBUILD b/extra/libinput/PKGBUILD
new file mode 100644
index 00000000..d4a9f2b4
--- /dev/null
+++ b/extra/libinput/PKGBUILD
@@ -0,0 +1,10 @@
+# break cycle with gtk3+
+if [ "${CARCH}" = "i486" ]; then
+ makedepends=(${makedepends[@]//gtk3/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /arch-meson/s/build/build -Ddebug-gui=false/
+ '
+ )"
+fi