summaryrefslogtreecommitdiff
path: root/extra/x265
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-02-28 16:26:50 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2019-02-28 16:26:50 +0100
commit3602bda3bf394e1e629c8b30e9defc0bb6b262df (patch)
treebeb6d89af59cb4e9dc1b27bf63011bb319405dfc /extra/x265
parentd5fa0c45743332c654ba88f53a0e792ee83b6c22 (diff)
downloadpackages-3602bda3bf394e1e629c8b30e9defc0bb6b262df.tar.xz
extra/x265: redone the CPU patch
Diffstat (limited to 'extra/x265')
-rw-r--r--extra/x265/0003-detect512-is-needed-on-all-architectures.patch12
-rw-r--r--extra/x265/PKGBUILD11
2 files changed, 8 insertions, 15 deletions
diff --git a/extra/x265/0003-detect512-is-needed-on-all-architectures.patch b/extra/x265/0003-detect512-is-needed-on-all-architectures.patch
index 16aab240..a5c65171 100644
--- a/extra/x265/0003-detect512-is-needed-on-all-architectures.patch
+++ b/extra/x265/0003-detect512-is-needed-on-all-architectures.patch
@@ -6,11 +6,10 @@ Subject: detect512 is needed on all architectures
source/common/cpu.cpp | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
-diff --git a/source/common/cpu.cpp b/source/common/cpu.cpp
-index 0681ff5..fa687da 100644
---- a/source/common/cpu.cpp
-+++ b/source/common/cpu.cpp
-@@ -110,6 +110,11 @@ const cpu_name_t cpu_names[] =
+diff -rauN a/source/common/cpu.cpp b/source/common/cpu.cpp
+--- a/source/common/cpu.cpp 2019-02-28 16:19:18.243333277 +0100
++++ b/source/common/cpu.cpp 2019-02-28 16:20:11.489999939 +0100
+@@ -110,6 +110,11 @@
{ "", 0 },
};
@@ -22,7 +21,7 @@ index 0681ff5..fa687da 100644
#if X265_ARCH_X86
extern "C" {
-@@ -123,10 +128,6 @@ uint64_t PFX(cpu_xgetbv)(int xcr);
+@@ -123,11 +128,6 @@
#pragma warning(disable: 4309) // truncation of constant value
#endif
@@ -30,6 +29,7 @@ index 0681ff5..fa687da 100644
-{
- return(enable512);
-}
+-
uint32_t cpu_detect(bool benableavx512 )
{
diff --git a/extra/x265/PKGBUILD b/extra/x265/PKGBUILD
index 29ddf3ba..efb3bbc1 100644
--- a/extra/x265/PKGBUILD
+++ b/extra/x265/PKGBUILD
@@ -1,14 +1,7 @@
-# disabling assembly code as it seems to be non-32-bittish
-
-eval "$(
- declare -f build | \
- sed '
- s/cmake/cmake -DENABLE_ASSEMBLY=OFF/
- '
-)"
# thanks, debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910963
+# repatched, 28.2.2019
source+=('0003-detect512-is-needed-on-all-architectures.patch')
-sha256sums+=('6baa25d11c81ad4ee49e9f2a367db4c770eb8cccf81f7bdaadb942621288a271')
+sha256sums+=('ce28ea0d35b2cebc95d733a67d6fbc7befb3b4f4fee2cf3e0c7d6f5b00e0e6dd')
eval "$(
declare -f prepare | \
sed '