summaryrefslogtreecommitdiff
path: root/extra/webkit2gtk
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-05-19 12:35:45 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-05-19 12:35:45 +0200
commit651722f2f0c15c62c753c73e088fe2f84e28f030 (patch)
treed2289ac1f42a1dfaba933a1e96e2d67f7ecf92a5 /extra/webkit2gtk
parent1eeb5f5bbf57f69de61a160a879cdcb435db0a14 (diff)
downloadpackages-651722f2f0c15c62c753c73e088fe2f84e28f030.tar.xz
extra/webkit2gtk: forgot to patch CMakeFiles.txt for SSE2
Diffstat (limited to 'extra/webkit2gtk')
-rw-r--r--extra/webkit2gtk/PKGBUILD2
-rw-r--r--extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch22
2 files changed, 23 insertions, 1 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index a61bef71..36799daa 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -1,7 +1,7 @@
# disable SSE2 on 486 and 686
if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
source+=('webkitgtk-2.24.1-no-sse2.patch')
- sha256sums+=('37b6ecf3918415fc0ad6662ea66ee77bf96c5343fcd80a243395e92b022b2d4e')
+ sha256sums+=('07bf1fc27fa3b92583e60297b390a6a3b048710b531f54af79a275db559bf548')
eval "$(
declare -f prepare | \
diff --git a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
index ffc2c6b3..9fdac3cc 100644
--- a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
+++ b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
@@ -1,3 +1,25 @@
+diff -rauN webkitgtk-2.24.1/CMakeLists.txt webkitgtk-2.24.1-no-sse2-patch/CMakeLists.txt
+--- webkitgtk-2.24.1/CMakeLists.txt 2019-04-08 12:45:38.000000000 +0200
++++ webkitgtk-2.24.1-no-sse2-patch/CMakeLists.txt 2019-05-19 12:33:45.378203751 +0200
+@@ -109,12 +109,12 @@
+ #---------------------------
+ # Make sure SSE2 is present.
+ #---------------------------
+-if (WTF_CPU_X86)
+- include(FindSSE2)
+- if (NOT SSE2_SUPPORT_FOUND)
+- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
+- endif ()
+-endif ()
++#if (WTF_CPU_X86)
++# include(FindSSE2)
++# if (NOT SSE2_SUPPORT_FOUND)
++# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
++# endif ()
++#endif ()
+
+ # -----------------------------------------------------------------------------
+ # Determine the operating system
diff -rauN webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
--- webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp 2019-02-12 12:21:18.000000000 +0100
+++ webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2019-05-17 14:43:51.042171245 +0200