summaryrefslogtreecommitdiff
path: root/extra/webkit2gtk
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-03-08 12:42:37 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2020-03-08 12:42:37 +0100
commit178bd4453b693ab3e107f14cfde4d9554af31a66 (patch)
treed5789fb5e1a15f4680bc170cf42968b8d2cc36fa /extra/webkit2gtk
parent747e8c86c7977e2d478a062cf8a0aab513a12c6c (diff)
downloadpackages-178bd4453b693ab3e107f14cfde4d9554af31a66.tar.xz
extra/webkit2gtk: redone non-SSE2 patching for i686
Diffstat (limited to 'extra/webkit2gtk')
-rw-r--r--extra/webkit2gtk/PKGBUILD8
-rw-r--r--extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.arch32.patch67
-rw-r--r--extra/webkit2gtk/webkitgtk-2.26.2-no-sse2-cmake.arch32.patch23
-rw-r--r--extra/webkit2gtk/webkitgtk-2.27.91-no-sse2.arch32.patch91
4 files changed, 95 insertions, 94 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
index a0ddcbbb..600ed141 100644
--- a/extra/webkit2gtk/PKGBUILD
+++ b/extra/webkit2gtk/PKGBUILD
@@ -1,8 +1,8 @@
# disable SSE2 on 486 and 686
-source_i486+=('webkitgtk-2.24.2-no-sse2.arch32.patch' 'webkitgtk-2.26.2-no-sse2-cmake.arch32.patch')
-source_i686+=('webkitgtk-2.24.2-no-sse2.arch32.patch' 'webkitgtk-2.26.2-no-sse2-cmake.arch32.patch')
-sha256sums_i486+=('e95391eceeb29d0ebc57d6b867afd7cd95ed92683edeb28c6a7a5048b5a9b85b' '48f46468c54518c3ce94b73321336a1f1aaf2d121b9222bc8d861726078b3001')
-sha256sums_i686+=('e95391eceeb29d0ebc57d6b867afd7cd95ed92683edeb28c6a7a5048b5a9b85b' '48f46468c54518c3ce94b73321336a1f1aaf2d121b9222bc8d861726078b3001')
+source_i486+=('webkitgtk-2.27.91-no-sse2.arch32.patch')
+source_i686+=('webkitgtk-2.27.91-no-sse2.arch32.patch')
+sha256sums_i486+=('27d1308e7a91c6c8e7b808c6f4213df35ffb309d877525d6b07483526f53e3b3')
+sha256sums_i686+=('27d1308e7a91c6c8e7b808c6f4213df35ffb309d877525d6b07483526f53e3b3')
if [ "${CARCH}" != "pentium4" ]; then
eval "$(
diff --git a/extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.arch32.patch b/extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.arch32.patch
deleted file mode 100644
index 5bcfb603..00000000
--- a/extra/webkit2gtk/webkitgtk-2.24.2-no-sse2.arch32.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -rauN webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp
---- webkitgtk-2.24.2/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp 2019-02-12 12:21:03.000000000 +0100
-+++ webkitgtk-2.24.2-no-sse2-patch/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp 2019-06-12 09:39:11.959999956 +0200
-@@ -12,6 +12,8 @@
- #include "common/platform.h"
- #include "image_util/imageformats.h"
-
-+#include <stdio.h>
-+
- namespace angle
- {
-
-@@ -28,6 +30,8 @@
- #if defined(ANGLE_USE_SSE)
- if (gl::supportsSSE2())
- {
-+ fprintf(stderr,"SSE2 detected but Webkit compiled without SSE2 support!\n");
-+
- __m128i zeroWide = _mm_setzero_si128();
-
- for (size_t z = 0; z < depth; z++)
-
-diff -rauN webkitgtk-2.24.2/Source/WebCore/platform/audio/SincResampler.cpp webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp
---- webkitgtk-2.24.2/Source/WebCore/platform/audio/SincResampler.cpp 2019-02-12 12:21:18.000000000 +0100
-+++ webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp 2019-06-12 09:36:23.089999961 +0200
-@@ -36,6 +36,7 @@
- #include <wtf/MathExtras.h>
-
- #if CPU(X86_SSE2)
-+#error No SSE2
- #include <emmintrin.h>
- #endif
-
-diff -rauN webkitgtk-2.24.2/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
---- webkitgtk-2.24.2/Source/WebCore/platform/audio/VectorMath.cpp 2019-02-12 12:21:18.000000000 +0100
-+++ webkitgtk-2.24.2-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2019-06-12 09:09:37.576666644 +0200
-@@ -33,6 +33,7 @@
- #endif
-
- #if CPU(X86_SSE2)
-+#error No SSE2
- #include <emmintrin.h>
- #endif
-
-diff -rauN webkitgtk-2.24.2/Source/WTF/wtf/Platform.h webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/Platform.h
---- webkitgtk-2.24.2/Source/WTF/wtf/Platform.h 2019-03-05 16:32:47.000000000 +0100
-+++ webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/Platform.h 2019-06-12 09:47:05.889999955 +0200
-@@ -124,7 +124,7 @@
- #define WTF_CPU_KNOWN 1
-
- #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
--#define WTF_CPU_X86_SSE2 1
-+/* #define WTF_CPU_X86_SSE2 1 */
- #endif
-
- #endif
-diff -rauN webkitgtk-2.24.2/Source/WTF/wtf/text/ASCIIFastPath.h webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h
---- webkitgtk-2.24.2/Source/WTF/wtf/text/ASCIIFastPath.h 2019-02-12 12:21:17.000000000 +0100
-+++ webkitgtk-2.24.2-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h 2019-06-12 09:35:37.626666634 +0200
-@@ -27,6 +27,7 @@
- #include <wtf/text/LChar.h>
-
- #if CPU(X86_SSE2)
-+#error No SSE2
- #include <emmintrin.h>
- #endif
-
diff --git a/extra/webkit2gtk/webkitgtk-2.26.2-no-sse2-cmake.arch32.patch b/extra/webkit2gtk/webkitgtk-2.26.2-no-sse2-cmake.arch32.patch
deleted file mode 100644
index 9d4c3451..00000000
--- a/extra/webkit2gtk/webkitgtk-2.26.2-no-sse2-cmake.arch32.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- webkitgtk-2.26.2/Source/cmake/WebKitCompilerFlags.cmake 2019-08-28 14:46:33.000000000 +0300
-+++ webkitgtk-2.26.2_nosse2/Source/cmake/WebKitCompilerFlags.cmake 2019-12-28 21:04:55.532144052 +0200
-@@ -139,13 +139,13 @@
- endif ()
-
- # Force SSE2 fp on x86 builds.
-- if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
-- WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
-- include(DetectSSE2)
-- if (NOT SSE2_SUPPORT_FOUND)
-- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-- endif ()
-- endif ()
-+# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
-+# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
-+# include(DetectSSE2)
-+# if (NOT SSE2_SUPPORT_FOUND)
-+# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
-+# endif ()
-+# endif ()
- endif ()
-
- if (COMPILER_IS_GCC_OR_CLANG AND NOT MSVC)
diff --git a/extra/webkit2gtk/webkitgtk-2.27.91-no-sse2.arch32.patch b/extra/webkit2gtk/webkitgtk-2.27.91-no-sse2.arch32.patch
new file mode 100644
index 00000000..a0413c72
--- /dev/null
+++ b/extra/webkit2gtk/webkitgtk-2.27.91-no-sse2.arch32.patch
@@ -0,0 +1,91 @@
+diff -rauN webkitgtk-2.27.91/Source/cmake/WebKitCompilerFlags.cmake webkitgtk-2.27.91-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake
+--- webkitgtk-2.27.91/Source/cmake/WebKitCompilerFlags.cmake 2020-02-25 14:02:33.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/cmake/WebKitCompilerFlags.cmake 2020-03-08 10:52:59.256386510 +0100
+@@ -140,13 +140,13 @@
+ endif ()
+
+ # Force SSE2 fp on x86 builds.
+- if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
+- WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
+- include(DetectSSE2)
+- if (NOT SSE2_SUPPORT_FOUND)
+- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
+- endif ()
+- endif ()
++# if (WTF_CPU_X86 AND NOT CMAKE_CROSSCOMPILING)
++# WEBKIT_PREPEND_GLOBAL_COMPILER_FLAGS(-msse2 -mfpmath=sse)
++# include(DetectSSE2)
++# if (NOT SSE2_SUPPORT_FOUND)
++# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
++# endif ()
++# endif ()
+ endif ()
+
+ if (COMPILER_IS_GCC_OR_CLANG AND NOT MSVC)
+diff -rauN webkitgtk-2.27.91/Source/ThirdParty/ANGLE/src/common/mathutil.h webkitgtk-2.27.91-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/mathutil.h
+--- webkitgtk-2.27.91/Source/ThirdParty/ANGLE/src/common/mathutil.h 2020-02-05 11:02:04.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/ThirdParty/ANGLE/src/common/mathutil.h 2020-03-08 10:57:13.602863895 +0100
+@@ -146,6 +146,7 @@
+ inline bool supportsSSE2()
+ {
+ #if defined(ANGLE_USE_SSE)
++#error No SSE2
+ static bool checked = false;
+ static bool supports = false;
+
+diff -rauN webkitgtk-2.27.91/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp webkitgtk-2.27.91-no-sse2-patch/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp
+--- webkitgtk-2.27.91/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp 2020-02-05 11:02:04.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/ThirdParty/ANGLE/src/image_util/loadimage.cpp 2020-03-08 10:57:55.570049890 +0100
+@@ -26,6 +26,7 @@
+ size_t outputDepthPitch)
+ {
+ #if defined(ANGLE_USE_SSE)
++#error No SSE2
+ if (gl::supportsSSE2())
+ {
+ __m128i zeroWide = _mm_setzero_si128();
+diff -rauN webkitgtk-2.27.91/Source/WebCore/platform/audio/SincResampler.cpp webkitgtk-2.27.91-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp
+--- webkitgtk-2.27.91/Source/WebCore/platform/audio/SincResampler.cpp 2020-02-04 11:24:07.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/WebCore/platform/audio/SincResampler.cpp 2020-03-08 11:04:31.904959427 +0100
+@@ -36,6 +36,7 @@
+ #include <wtf/MathExtras.h>
+
+ #if CPU(X86_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+
+diff -rauN webkitgtk-2.27.91/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.27.91-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
+--- webkitgtk-2.27.91/Source/WebCore/platform/audio/VectorMath.cpp 2020-02-04 11:24:07.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2020-03-08 11:05:13.875479720 +0100
+@@ -33,6 +33,7 @@
+ #endif
+
+ #if CPU(X86_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+
+diff -rauN webkitgtk-2.27.91/Source/WTF/wtf/PlatformCPU.h webkitgtk-2.27.91-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h
+--- webkitgtk-2.27.91/Source/WTF/wtf/PlatformCPU.h 2020-02-04 11:24:07.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/WTF/wtf/PlatformCPU.h 2020-03-08 11:06:26.063041396 +0100
+@@ -99,7 +99,7 @@
+ #define WTF_CPU_KNOWN 1
+
+ #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
+-#define WTF_CPU_X86_SSE2 1
++/* #define WTF_CPU_X86_SSE2 1 */
+ #endif
+
+ #endif
+diff -rauN webkitgtk-2.27.91/Source/WTF/wtf/text/ASCIIFastPath.h webkitgtk-2.27.91-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h
+--- webkitgtk-2.27.91/Source/WTF/wtf/text/ASCIIFastPath.h 2020-02-04 11:24:07.000000000 +0100
++++ webkitgtk-2.27.91-no-sse2-patch/Source/WTF/wtf/text/ASCIIFastPath.h 2020-03-08 11:06:54.516727539 +0100
+@@ -27,6 +27,7 @@
+ #include <wtf/text/LChar.h>
+
+ #if CPU(X86_SSE2)
++#error No SSE2
+ #include <emmintrin.h>
+ #endif
+