summaryrefslogtreecommitdiff
path: root/extra/texmacs/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-12-29 19:17:12 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2017-12-29 19:17:12 +0100
commitd192374db8fbf71b06a8ab9f4996903b5d34c357 (patch)
tree9880a897cc199751c4384beb98f2e619ea08bce4 /extra/texmacs/PKGBUILD
parentbad4a1669ce654599c6560c35917be4b873c0b04 (diff)
downloadpackages-d192374db8fbf71b06a8ab9f4996903b5d34c357.tar.xz
extra/texmacs: fixed test for guile_size_t to be a size_t and not an int
Diffstat (limited to 'extra/texmacs/PKGBUILD')
-rw-r--r--extra/texmacs/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/texmacs/PKGBUILD b/extra/texmacs/PKGBUILD
new file mode 100644
index 00000000..6469e015
--- /dev/null
+++ b/extra/texmacs/PKGBUILD
@@ -0,0 +1,10 @@
+# guile cmake checks allow int* to be casted to size_t*, so we
+# add -fpermissive to make the int cast fail and the size_t cast
+# succeed
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cd TeXmacs-${pkgver}-src/ a \ sed -i "/SET(CMAKE_REQUIRED_FLAGS/s/-Werror /-Werror -fpermissive /" CMakeLists.txt
+ '
+)"